warning can't access (null) 
exec of unit (null) failed !! :14
unmount /initrd/dev failed :2
kernel panic - not syncing : attempted to kill init!

Update 01 - i couldn't fint /etc/fstab and couldn't find /boot/grub/menu.lst i mount my filesystem partition again coz it wasn't mounted and when i do

df -i

i found /tmp/loop0 mounted on /mmnt/runtime and inodes free is zero it's 100% full i really don't know what is that i go inside it and i found etc , lib , modules , proc , usr , var never mind

when i go to my file system i found lib , pin ,var are not a directory i do e2fsck -fpv /dev/sda5 <--- which is my file system is here and it's done when i reboot nothing change same error appear :( what did u suggest me to do ?

asked 11 Jul '10, 12:55

khaled's gravatar image

khaled
2512
accept rate: 0%

edited 20 Apr '11, 11:57

rfelsburg's gravatar image

rfelsburg ♦
6061618

Please consider adding 4 spaces in front of your code/quotation so that it's more readable.

(13 Jul '10, 12:22) guerda

Please accept an answer so the question/answer can be finished.

(20 Apr '11, 13:39) rfelsburg ♦



We need a little more information.

Is this happening when you logout, login, try and mount a volume?

Can you give precise info on what you are doing, or trying to do for that matter.

However to give a push in the right direction: It looks like filesystem corruption, did you recently have an outage, or have a hard shutdown?

Also what filesystem is this? ext3, ext2?


UPDATE 01

Essentially your filesystem is corrupt in some parts. It can't find what to mount. When you boot in with the boot disk, can you see /etc/fstab and /boot/grub/menu.lst?

When you boot, it's missing a number of files it needs such as /var which you stated looks like a file instead of a directory.

The next step would be to boot in with a boot disk, and run fsck on the unmounted

e2fsck -fpv

The above command will auto-repair the filesystem, and will force it to run even if the filesystem appears clean. The -v flag tells it to be verbose, log all the output in case you need to refer back to it.

If it comes across an error that requires further intervention it will print it to the screen.

Do the above and then come back and let us know whether it worked. We'll go from there.


UPDATE 02

Maybe I was unclear, when you boot with the rescue cd it normally mounts the filesystem to /mnt/sysimage

You then have the option of chrooting to /mnt/sysimage which would make it so your filesystem is at / effectively.

Assuming you are NOT chrooting to /mnt/sysimage your files would be located at /mnt/sysimage/etc/fstab and /mnt/sysimage/boot/grub/menu.lst

Check for those files in those locations. Also check and see if /mnt/sysimage/var is a directory as well.

You can try running fsck again as well, but after 3-4 times of running you may have to accept the filesystem is isn't able to be repaired by fsck.

Are they present? if not and you have tried fsck'ing the filesystem you may be out of luck. If your filesystem is corrupted the next step after this would be to salvage your user data and go from there.

link

answered 13 Jul '10, 17:08

rfelsburg's gravatar image

rfelsburg ♦
6061618
accept rate: 25%

edited 13 Apr '11, 11:28

this error appear when i start the server and after that it didn't start i try rescue mode and it didn't work when i go to rescue mode it gives me the prompt i find that /var is not a directory and i find the fdisk was like corrupted i just need to recover the operating system and this happens after it restart by it self file system is ext3 thanks for your help

(14 Jul '10, 07:56) khaled

http://www.gossamer-threads.com/lists/syslinux/users/6770

This would probably be the easiest explanation without typing it all out. Just FYI. www.google.com/linux is a good way to research.

link

answered 11 Jul '10, 16:17

MigrationKing's gravatar image

MigrationKing
41126
accept rate: 0%

WOW!! There are some good answers here, all of which I'd recommend, so I'll just add my little 2 cents here.... check /var/log and also dmesg... the first step of any troubleshooting is data-gathering, followed by the next step of sorting, filtering, and disseminating said gathered information so you can now make a proper assessment and then either proceed to gather more/different data, or fix the issue directly based on information gathered.

link

answered 13 Apr '11, 13:57

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×10

Asked: 11 Jul '10, 12:55

Seen: 9,571 times

Last updated: 20 Apr '11, 13:39

powered by OSQA