I have downloaded RHEL 6 beta from www.redhat.com site and installed it on my PC successfully. When I want to login with root in GNOME/KDE, the system gives me a error message that AUTHENTICATION FAILED and I'm unable to login while I can login with root from terminal/text mode.

But I can login with other user or local user successfully.

Please help me and solve my this problem.

This question is marked "community wiki".

asked 13 Jul '10, 10:15

Ashi%20Sharma's gravatar image

Ashi Sharma
124
accept rate: 0%

edited 20 Jul '10, 19:10

rfelsburg's gravatar image

rfelsburg ♦
6061618




First off: The usual lecture about not using root for routine tasks, or use sudo if you need to. Now your actual problem.

It sounds like your login manager is not letting you login as root, which means either gdm, or kdm.

Their was a change made in fedora that fits this description. I know they disabled root logins via gdm and pam.

For Gnome:

Look at /etc/pam.d/gdm

Look for the line:

auth required pam_succeed_if.so user != root quiet

If it's there make a copy of the original file, and delete the line.

If your using kde, youll need to look at your kdmrc file, and change AllowRootLogin to true

link
This answer is marked "community wiki".

answered 13 Jul '10, 15:49

rfelsburg's gravatar image

rfelsburg ♦
6061618
accept rate: 25%

1

Why was this made community wiki, I've been looking and can't really find any criteria for what this defines?

(13 Jul '10, 20:26) rfelsburg ♦

I've added the answer to this question to the FAQ.
--jeremy

(15 Jul '10, 19:25) jeremy ♦♦

Thanks Jeremy, I was more interested in why someone else would tag my post as community wiki only a couple of hours after it was made.

Thanks

(20 Jul '10, 18:08) rfelsburg ♦

rfelsburg is right - your permission comes from gdm. Changing that gives you a root GUI.

HOWEVER...

Just in case you're a newbie...

Most distros DO NOT ALLOW one to login as root, only to su to root after logging in. Blocking root login is a common security practice (Fedora does it, for instance.)

Allowing root login is a big security hole - anyone can come in over the net and bang away at your login screen. If they can login as root, you've just handed them the keys to your castle. By making it a two-step process you've at least slowed them down and left more tracks in your system logs.

see: http://www.cyberciti.biz/tips/linux-security.html Look at item #7

or http://www.howtogeek.com/howto/linux/security-tip-disable-root-ssh-login-on-linux/

Good Luck.

link
This answer is marked "community wiki".

answered 20 Jul '10, 18:00

DBA's gravatar image

DBA
2264
accept rate: 23%

Keep in mind the differences between ssh and a gui login to gnome, or kde. This is an important differentiation, disabling root logins to ssh is indeed common practice. However not allowing root logins to gnome/kde is a fairly new practice.

The OP is talking about a login to gnome/kde, not ssh.

(20 Jul '10, 18:09) rfelsburg ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×15
×14
×7
×5
×2

Asked: 13 Jul '10, 10:15

Seen: 6,622 times

Last updated: 30 Mar '11, 07:23

powered by OSQA