Hola, I need to ask you about my Postfix mail server, it can send mails internal to my domain, but really when i try to send mails to gmail or yahoo or any other mail provider my message go to mail queue. Also when i try to send mail from any mail provider to my mail server, the mail server don't receive any thing. My Linux platform is : Linux Centos 5.4 My mail server is : postfix thanks in advance :D

asked 22 Apr '10, 07:14

Network%20Systems%20Engineer's gravatar image

Network Syst...
2415
accept rate: 16%

Please accept an answer, or provide more details so we can help.

(14 Jun '11, 11:35) rfelsburg ♦



Thanks my friend, but really i talk to my ISPabout blocking mail traffic and he told me that i must put some of its relay parameters in my outgoing mail server, so now what i need is these steps :D

link

answered 25 Apr '10, 06:30

Network%20Systems%20Engineer's gravatar image

Network Syst...
2415
accept rate: 16%

You should really edit the previous answer rather than posting a new answer (in fact you should put both of your answers into the question - maybe marked as an EDIT or as a SOLUTION).

(28 Apr '10, 13:25) Amos

configure your postfix to relay to your ISP's email server.

include in your main.cf file (normally found at /etc/postfix) the parameter:

relayhost = [your_isp's_smtp_relay]

your ISP may receive your relays without problem since you are a registered user. but if smtp authentication is required, check http://www.postfix.org/SASL_README.html#client_sasl to configure your postfix to authenticate properly during relaying.

hope this helps.

(11 May '10, 20:33) wim

First things to do: check if MX records are correct(and mailserver can access working DNS server), if your mailserver external IP is static, if you have connections from/to when sending/receiving. Logs can tell much too.

link

answered 22 Apr '10, 11:14

Web31337's gravatar image

Web31337
317111
accept rate: 11%

1) You required reverse dns for your domain .Because all the reputed mail server will check that,If it's not available that assume this a spam generator. So just crate MX record and reverse DNS for your domain.

2)run the below mentioned command and check the log .As well here share that through that we can reach success .

tail -f /var/log/maillog

Thks -Cheers $Prakash

link

answered 23 Apr '10, 02:58

prakash's gravatar image

prakash
111
accept rate: 0%

Really thanks for the reply, but i make the last command which is

tail -f /var/log/maillog

the result was

Apr 24 10:40:06 abakhiet postfix/smtp[3225]: 266941182F2: to=<**somemailaddress**>, relay=none, delay=156, delays=0.11/0.11/156/0, dsn=4.4.1, status=deferred (connect to e.mx.mail.yahoo.com[67.195.168.230]: Connection timed out)

so, what can i do ???

link

answered 24 Apr '10, 08:47

Network%20Systems%20Engineer's gravatar image

Network Syst...
2415
accept rate: 16%

Check firewall settings, connecting 67.195.168.230:25 works for me even from dynamic IP.

(24 Apr '10, 13:24) Web31337
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6
×6
×6
×2
×1

Asked: 22 Apr '10, 07:14

Seen: 4,621 times

Last updated: 14 Jun '11, 11:35

powered by OSQA