I need some troubleshooting help with a wireless network problem.

I can connect wirelessly using /etc/network/interfaces. ifup wlan0 gets an address via dhcp and all works well. However, I have to click and disable the network manager trying to connect in order for this to work.

If I let gnome network manager connect, it does not succeed. I am getting in daemon.log: NetworkManager: Device 'wlan0' IP6 addrconf timed out or failed.

Interestingly, gnome network manager succeeds in connecting to public networks in coffee shops. This makes me think something is not properly set up at my home router.

Any suggestions? Thanks!

asked 21 Jul '10, 14:19

Matyas's gravatar image

Matyas
1123
accept rate: 0%

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 14:13) rfelsburg ♦

Your router probably does not support ipv6 (not many do right now), not an answer, just a comment. To use ipv6, you'll need a newer/different router (or firmware). You can also do 6-to-4 tunneling through a free service if need be.

(02 Aug '11, 15:18) Ron ♦



Check the configuration file for wlan0. could be you have it set to look for an ipv6 address.

What distro are you using?

link

answered 21 Jul '10, 15:13

rfelsburg's gravatar image

rfelsburg ♦
6061618
accept rate: 25%

I am using debian. I was not aware of a configuration file for wlan0 specifically. /etc/network/interfaces has:

iface wlan0 inet dhcp wireless-essid [...]

I grepped for IPv6 in /etc and I will follow through the hits. I was kind of ignorant about the IPv6 IPv4 stuff until now.

Any furthe pointer would be appreciated.

(23 Jul '10, 18:39) Matyas

I tried: echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf and: GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1" the problem persists. Maybe gnome-network-manager is broken?

(27 Jul '10, 18:08) Matyas

I'm under the impression that you may be going the wrong way about it. If by gnome-network-manager you are refering to the gnome applet to control Network Manager, why are you using the ifupdown infrastructure at all? They conflict. Comment out the lines pertaining to wlan0 in /etc/network/interfaces and configure your connection with Network Manager applet. Simply select the network you want to connect to in the menu, give the password, store it if you want (it is optional) and let Network Manager do its thing.

link

answered 02 Aug '11, 13:03

vorbote's gravatar image

vorbote
312
accept rate: 0%

edited 02 Aug '11, 13:04

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×23
×17

Asked: 21 Jul '10, 14:19

Seen: 4,911 times

Last updated: 02 Aug '11, 15:18

powered by OSQA