I moved to Fedora 13 from Vista and I'm having issues with DVD+R burning.

On Vista I actually burned the Fedora ISO to install, and Fedora can read the DVD+R burned disc. But, now I insert a blank DVD+R but somehow it can not get the size of the disk correctly. The disk is recognized, and mounted as "Blank DVD+R Disc", but when I Right-Click on the icon on my desktop it says 0 bytes used, 0 bytes free.

When I try Brasero, it tells me that there is not enough space to burn.

My DVD is a Toshiba DVDW/HD TS-L802A firm. HP21.

CD's work fine, any ideas?


Andrés Arenas V.

http://www.arenasa.com/

asked 23 Jul '10, 13:08

Andres's gravatar image

Andres
7615
accept rate: 20%

edited 25 Jul '10, 21:36

When you say CDs work fine, do you mean you have been successful at burning CDs via Fedora 13?

(26 Jul '10, 20:18) Andy

Yes, I can burn CDs

(28 Jul '10, 19:28) Andres



These are just guesses

Have you ever successfully written a DVD on your installed system? How about a bootable .iso? (It sounds like you're trying to write an .iso and get a bootable dvd.)

  • Could it be the way you're using brasero?

A possibility is the way you're using brasero (which I've only used once.) Are you trying to use it to write an .iso image? If so, that's different from writing the .iso image into an iso file system as data. (I.e. If you're using the "data project" option, the file system itself takes space, so there may not be enough room for the .iso file and in any case it would only show up as a data file. You'd have to use the "burn image" option to do a raw copy and get a bootable DVD.

  • Could it be a permissions problem?

The Fedora install should have gotten this right, but sometimes there's a glitch. You may be a victim of Murphy.

Type ls -l /dev/dvd. That should be a symbolic link to your actual device (say /dev/sr0).

Then type ls -l /dev/sr0. Look at the permissions and groups. Chances are that /dev/sr0 is owned by root and group cdrom. Chances are also that the permissions for sr0 are "brw-rw----"

Then become yourself again and type "groups". Chances are that you are NOT a member of cdrom. If so, you do not have permission to access the device directly for write.

Now do a "ls -l" on the program you're using to try to write to the device (brasero). If IT also doesn't have proper permissions, you'll never get it to write.

  • Personally, I've found K3b to be easier and more reliable to use than brasero. I once tried to burn an iso image using brasero and ended up with a coaster. Using K3b I've never had a failure.

Good Luck.

link

answered 28 Jul '10, 16:27

DBA's gravatar image

DBA
2264
accept rate: 23%

edited 28 Jul '10, 16:39

OK, I was able to burn DVDs on Windows, after Installing Fedora I can't. I checked your suggestions on permitions, but everything looks normal, now I found some errors in /var/log/messages: | kernel: ILI | kernel: sr 3:0:0:0: [sr0] Add. Sense: Illegal mode for this track | kernel: sr 3:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00 | kernel: end_request: I/O error, dev sr0, sector 0

(28 Jul '10, 19:39) Andres

I will try with new a blank DVD to discart media problems, I think I already tried that in the past.. but to be sure. I will post any result here.

(28 Jul '10, 19:44) Andres
2

OK, it seems it is a known issue since Fedora 10, there is a bug on Bugzilla reporting the issue https://bugzilla.redhat.com/show_bug.cgi?id=542021 , if I find anything new I will report.

(29 Jul '10, 02:21) Andres

I use k3b, and indicate I want to burn an iso image. K3b works just fine, and I have burned hundreds if not more CDs and DVDs. If it is an iso, use the tools tab with k3b to select burn an iso image.

link

answered 03 Apr '11, 22:25

lsatenstein's gravatar image

lsatenstein
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×24
×6

Asked: 23 Jul '10, 13:08

Seen: 6,804 times

Last updated: 03 Apr '11, 22:25

powered by OSQA