I am trying to view some web pages I made on Debian in the /srv folder with Apache running. I tried telling the terminal to change the permissions to make my regular user account the owner, but it keeps saying in properties I am not the owner and cannot put files in the folder. The terminal is ignoring me, not even telling me it isn't making changes. Here is what I typed to try and correct it from the root terminal:

chown doug /srv

&

chmod 755 /srv

Thanks. Not really a total newb to Linux, just a little rusty.

asked 21 Aug '10, 21:51

Doug's gravatar image

Doug
11
accept rate: 0%




I resolved this myself. For some reason when I used:

chmod -R +rw /var/www

...and closed and opened the folder properties again it worked...was trying to set permissions on the wrong folder anyway. Apache is in a different path than I thought it was when I used OpenSUSE 11.0 and Apache as a web server a couple years back. I got gremlins. They live in the walls. The cats can't fight 'em off no more.

link

answered 22 Aug '10, 02:46

Doug%201's gravatar image

Doug 1
261
accept rate: 100%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×26
×2

Asked: 21 Aug '10, 21:51

Seen: 2,247 times

Last updated: 22 Aug '10, 02:46

powered by OSQA