I added a raid drive to my computer and created an entry in /etc/fstab to mount it. The problem is that it doesn't mount at startup. I have to go into System->Administration->Disk Utility. From there I have to start the raid array. Then I can mount it. How can I make it automatically mount at startup?

asked 23 Aug '10, 02:17

Phenom's gravatar image

Phenom
1158
accept rate: 0%




What kind of RAID? Software (mdadm)? Make sure that mdadm is configured properly, that the kernel modules are loaded at boot time and that mdadm is starting at boot time. If you have already done that, check your dmesg output to see why mdadm doesn't start at boot.

link

answered 23 Aug '10, 06:29

Sander%20Marechal's gravatar image

Sander Marechal
398116
accept rate: 29%

You can boot from a RAID0 or RAID1. You cannot boot from a RAID5.

link

answered 24 Aug '10, 03:33

teddymills's gravatar image

teddymills
111
accept rate: 0%

Do you mind posting what you have in /etc/fstab for this RAID drive? Check if you don't have the option noauto in the line. If you do remove it and try the command mount -a to see if it mounts. Then reboot to perform the final check.

link

answered 24 Aug '10, 17:09

EricTRA's gravatar image

EricTRA
564
accept rate: 7%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6
×4

Asked: 23 Aug '10, 02:17

Seen: 2,227 times

Last updated: 23 Mar '11, 04:23

powered by OSQA