Hi,

OK, at the risk of a tornado, here is a question. I tried (several times with no success) to install F12 on a Compaq. A simple enough little thing, 1.5Gb memory, 250Gb hard drive, fast enough, hey, one of those ultra slimlines. Installing in graphical mode seems to be a problem, VESA is required. I can survive on VESA, no sweat. But after reboot, the machine cannot find the boor partition. I cannot reboot, the thing screams this:

Kernel panic - not syncing : VFS: unable to mount root fs on unknown-block(0,0)

A Compaq issue? I'm at the fork in the road here: either change distro (dont wanna, I like RH/Fedora - but if I HAVE to...) or get a "white"/non-brand brand-new PC (for once, I only have second hands)

Ok, some intel/feedback would be nice...it is sunday afternoon, so, hey...

Wellness!

Thor

asked 25 Apr '10, 15:14

Thor's gravatar image

Thor
7615
accept rate: 20%

edited 28 Apr '10, 17:16

Kevin%20M's gravatar image

Kevin M
11215

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 13:54) rfelsburg ♦



The system is trying to tell you it can't find the hard drive !don't panic! it wasn't stolen, the problem is that you installed in a different partition.

There are two solutions. Number 2 should be easier if you are more of a newbie (not that is anything wrong with that), Number 1 needs a little more knowledge but could be faster.

2) Just check there are no hidden partitions in the disk (laptops usually have one of those for the default installation) and re-install.

or

1) You may change the boot options to the second (third, etc) partition until it works. Then modify your grub or lilo accordingly.

link

answered 29 Apr '10, 01:08

LiquidPaper's gravatar image

LiquidPaper
12113
accept rate: 0%

Hi,

I may just give that a whack...the itch is, the thing does not boot - I may have to do that with a live CD (that does boot/work) mount the hard drive and play with that.

And...option 1 seems easier to me...what does that tell me, eh?? (happy to use Linux - the system that WORKS)

Thanks!

Thor

(13 May '10, 17:19) Thor

If you can load a livecd, then try editing the grub.conf to point to the label for the root device. Your syntax might look like ROOT=LABEL=/. Or, if it is already this way, then try switching it to a hd(0,0) syntax.

link

answered 28 Apr '10, 17:21

Kevin%20M's gravatar image

Kevin M
11215
accept rate: 25%

Hi,

Tnx 4 answering...

I've come across this...editing some stuff, does that mean I need to re-burn the ISO? The system is one of those ultra-slim lines with a drive that is the same as a laptop (a PC/Laptop combo?) Did not find a hidden partition. Funny that centOS DOES run nicely...

I wanted this system to be the next PC I use, hace annother compaq E51 now...

Tnx

Thor

(13 May '10, 17:12) Thor

You shouldn't have to re-burn the ISO. Boot using the live CD, then mount your /boot partition(or your / partition if you don't have a boot) and edit the appropriate file there.

(14 May '10, 02:17) Kevin M

Hi,

Well, problem solved...guess what, I think the Ultra-Slim line Compaq is actually a ... laptop. There was a partitioning problem.

I pieced all of the tips given here together and this came out: I started up with the F12 live CD, entered the console became su (not suE, but Super User LOL) ran "fdisk -l" to find out what's out there, used parded to kill everything on the hard drive (250Gb new SATA - is there supposed to be something on a NEW hard drive???) and reinstalled the whole slew - only NOW...Anaconda asked me where to put the boot loader, it never did THAT before. Then I knew it was right-on.

Next are some tweaks-n-stuff and I'm off into the F12...

Thanks for all the good tips...and guess what, I'll write all of that down, just for next time!

Wellness to all of ya!

Thor

link

answered 06 Jun '10, 09:19

Thor's gravatar image

Thor
7615
accept rate: 20%

Some questions that occur to me:

  • Did you have a Linux install on the machine previously? (ie has it worked in the past)
  • Can you run a live distro successfully on the machine?
  • Has the bootloader (grub? or lilo?) installed correctly?

EDIT (more ideas)

  • Is this a laptop? If so what model number (there may be info about it around on t'internet).
  • Are you you dual booting?
  • Does the laptop come with some sort of secure bootloader pre-installed by the manufacturer?
link

answered 28 Apr '10, 11:11

Amos's gravatar image

Amos
1321312
accept rate: 0%

edited 28 Apr '10, 17:31

Hi,

No previous install. What I did do - after asking THIS question is install F8, then upgrade to F12. Had to edit the yum repos though. Did a re-compile of the kernel - to get sound on Java...then it did work. Until I had an update...then the thing went dead again...

Lucky this is a play-around PC, if THAT were my main PC... :D

Thor

(13 May '10, 17:16) Thor

Have you tried GAG? It's a graphical boot loader that doesn't even need to be installed if you want to try it first...
basically it allows to choose a partition and attempt to boot off it... worth having a look but please note that it will only boot from partitions where a loader already exists (like LILO or GRUB) meaning that if you chose to have these installed in the MBR, then it won't work but you can still use a LiveCD to install LILO or GRUB on the partition itself and then use GAG which might still help in case Compaq does something strange at boot time or as others have said, there is a hidden partition causing trouble...

http://en.wikipedia.org/wiki/GAG_%28boot_loader%29

link

answered 07 Jun '10, 18:20

pmarini's gravatar image

pmarini
286216
accept rate: 28%

Hi,

No, never heard of it. But then, I only use Linux, so a choice is irrelevant. The problem was indeed that there was something on that *** disk :D already, once removed, I was in the clear. F12 runs like a charm, just need to get sound in the JRE and I can hop over...

wellness

Thor

(25 Jun '10, 19:37) Thor
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×24
×4
×1
×1

Asked: 25 Apr '10, 15:14

Seen: 2,593 times

Last updated: 20 Apr '11, 13:54

powered by OSQA