Hello everyone. I'm using Slackware13.0 & I've encountered a rather perplexing situation. I was wondering if there where any fellow slackers or wizened gnu 'rus out there who could lend a hand.

While using the kde4 desktop environment, after using the suspend to ram feature, I cannot revive the other consoles? tty0-7, or the consoles you get when you ctrl+alt+fn". The only one I can revive is the one I last used; xwindows, or tty7.

If anyone could help point me in the right direction towards a resolution, I'd be most grateful!

asked 25 Apr '10, 19:48

Slug's gravatar image

Slug
3113
accept rate: 0%

edited 25 Apr '10, 19:56

I'd love an answer that includes the 7th as well.. mine just sits there with the caps lock light blinking waiting for a hard power-off.. nothing else works. No other consoles in use (single user laptop)

But, if you are having some success, perhaps you could restart the other consoles http://bbs.archlinux.org/viewtopic.php?id=76840

(05 May '10, 02:07) Grizly

I am not entirely sure if this is relevant but might you be using a binary graphics driver like NVIDIA?

(07 May '10, 01:56) kasbah

Grizly, that post got me thinking. I ran ps auxT as root (T option lists pid with tty). Exactly like the archlinux post, I found root still had active agetty tty's attached:

/sbin/agetty 38400 tty2 linux

.. from tty2 to tty5. tkdfighter on the forum mentions he was able to revoke the console via

/sbin/agetty -8 38400 vc/1 linux

vc/1 looks to be archlinux syntax... I tried both commands without success.

I checked http://humanreadable.nfshost.com/sdeg/gui_startup-2.htm", looks like agetty is spawned with the init process.

@ Kasbah: I am using the Nvidia binary driver.

Any ideas?

(12 May '10, 06:56) Slug

.. and thanks everyone for your input, hopefully we can figure something out!

(12 May '10, 07:01) Slug



I've never heard of a problem like that. Those other consoles could be in use... possibly..? Try:

cat /etc/passwd | cut -d":" -f1

and then run:

top

The first should list all your users and the second all processes... See if any are actually logged into and using another console

link

answered 04 May '10, 03:40

Jub's gravatar image

Jub
1362
accept rate: 14%

Top shows processes belonging to root and the user tied with the x session. 2 users total while running top as root. No other users are in the list.

(12 May '10, 06:26) Slug

I would attempt to boot without framebuffer console graphics mode. The kernel switch to turn that off should be "nofb". I don't know if Slack uses a graphical boot mode (like the rhgb option), but if it does, I would turn that off as well.

http://www.nvnews.net/vbulletin/showthread.php?t=49005

link

answered 11 May '10, 20:22

memnoch_proxy's gravatar image

memnoch_proxy
1413
accept rate: 42%

hmm.. that is a good point. However, I disabled framebuffer (fbdev) a while ago. I was testing configurations when I noticed my machine booted faster without it.

(12 May '10, 06:31) Slug

Have been googling an LVM question on Slackware and came across this great slackware tips and tricks with explicit instructions on tweaking a couple may apply: link text

What run level are you using? I don't use KDE although its installed but sometimes Xserver blinks out and I alt ctrl till I get another terminal then shutdown as root. Are you using a laptop or desktop? Wireless keyboard or PS2? Caps lock blinking - batteries for the keyboard? $ps aux shows tty7 as root. For me first line is tty3 and tty1 the one i am using. Do you have 3 or 4'initdefault'... Goto the above link it will walk you through your startup 'display manager' settings, edit /etc/rc.d/rc.4 and change the order of preferred display managers, so kdm is first. Let us know if it works ;) Problem solve in this post: link text

link

answered 13 Sep '10, 09:04

udot's gravatar image

udot
12
accept rate: 0%

edited 13 Sep '10, 09:35

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×11
×7
×4
×4
×2

Asked: 25 Apr '10, 19:48

Seen: 2,923 times

Last updated: 29 Mar '11, 08:05

powered by OSQA