Hi,

As this is my first ever post, please excuse me if I have overlooked some obvious source of info.

I seek help with getting a virgin Mobile Broadband G3 dongle working under Ubuntu 10.04 on a Dell laptop. I think I am quite close to having done it, but I can't quite get there. The problem may simply be that I do not know what to respond to the network manager.

The dongle is badged as Alcatel. When I plug it in, it initially flashes orange, then - now that I have installed usb_modeswitch - it changes to flashing green, which I think looks promising. (However under some circumstances it changes from green to red later)

The outputs from lsusb with and without the dongle inserted differ by the line:-

Bus 002 Device 005: ID 1bbb:0017 T & A Mobile Phones

I'm not sure what I expect to happen, but nothing does. So I assume I need to configure it with the network manager. Here I get stuck.

Going to the main menue on the upper panel and following system->preferences->network connection->Mobile Broadband->Add, I am offered a few screens in which I am asked the Provider's country, namelyBritain(UK), The Provider for which I choose Virgin Mobile from a list of options

I am then asked my plan, which I do not know, and I have not found anyone at Virgin who will tell me (even when they understand my question). Consequently I have just accepted the suggested "default". The same screen asks me for my plan's APN, but the dialogue box for the APN is not active, so I cannot enter it there. The box contains a feint "vdata", the significance of which I don't know, so I have tried clicking Apply.

That takes me to a screen which, under the tag "Mobile Broadband" has some details which I appear to be able to change, including vdata

Under "Basic" I have number as *99#, and username and password both blank. From reading posts by people who have made this work, I believe those are correct responses.

Under "Advanced" I have APN as vdata and Network and Pin both blank. Again from other posts I think the two blanks are probably correct, but I believe that vdata should be something else. I have tried changing it to VirginMobile and to VirginBroadband but neither appears to get me any closer to a connection. Again I have hit a brickwall trying to get anyone at Virgin Media to tell me what the APN should be.

Any suggestions welcome.

asked 10 Nov '10, 16:20

BobH's gravatar image

BobH
1111
accept rate: 0%




Your question is laid out well and I dod understand it, I think really before you can proceed, you need that APN. It sounds like the hardware itself is installed, and you can certainly verify that with kshw or dmesg, but this seems to be a settings issue more than a hardware issue, so correct me if I'm wrong on that...... but the only people who can give you the specific information about your APN, account information, etc, is Virgin Mobile. Have you called their corporate offices?

link

answered 10 Nov '10, 18:39

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

Hello. I had the same problem having just signed up to Virgin mobile broadband, but have (luckily) solved it (after a struggle). Thanks to Sakis.

What I have :

  • Virgin Mobile 3G monthly contract (UK).
  • X220S Alcatel USB stick
  • Acer Aspire One Netbook (AOA 150-Bb)
  • Ubuntu 10.10 Netbook Edition

What I did :

sudo apt-get purge modemmanager
sudo reboot  # to make sure modemmanager is killed and gone
./sakis3g   # download from http://www.sakis3g.org/

APN : goto.virginmobile.uk
User: user
Password: anything

Then the flashing green light should stop flashing and stay on - you are connected. In firefox untick 'offline' and it works despite Network Manager icon saying you don't have an internet connection! See the forum and instructions on Sakis website.

Matthew

link

answered 22 Nov '10, 23:01

mdo's gravatar image

mdo
11
accept rate: 0%

edited 25 Nov '10, 09:42

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81
×11

Asked: 10 Nov '10, 16:20

Seen: 11,857 times

Last updated: 17 Mar '11, 14:23

powered by OSQA