I downloaded a ATI fglrx driver from the repository in Ubuntu 10.4 to help with my resolution. When I rebooted after splash, the monitor went to sleep. I am going to go into recovery mode to try and fix this. What code should I use to purge what I did and restore to default? Thanks in advance

asked 03 May '10, 13:19

Michael%20Forsberg's gravatar image

Michael Fors...
1112
accept rate: 0%

edited 11 May '10, 09:41

guerda's gravatar image

guerda
5533515

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 13:52) rfelsburg ♦



 sudo /usr/bin/dpkg --purge <fglrx's package name here>

- though in recovery mode you're logged in as root I think, so you won't need the "sudo"

This will remove the package & any config. You haven't said what your prior situation was, but this should help. You didn't say if you're using an X config file,but it may be worth making sure if there's any /etc/X11/xorg.* files & if there are, checking if they mention 'fglrx' You could do this with

 /bin/grep "fglrx" /etc/X11/xorg.*

but there probably won't be any though.

When you ask a question you should probably supply a lot more info about your system, like what video card, what the relevant thing's setup was before you changed it, & any error messages. When you say the monitor "went to sleep" its not really clear what state your system was actually in, as usually if the X driver fails then you drop back to the console. When X starts up it creates a log file "/var/log/Xorg.0.log which will contain any error messages,also the previous one that has ".old" appended to the filename which you can compare.

If the "radeon" driver works with your card it may be worth trying afterwards also

link

answered 03 May '10, 13:55

gouchout's gravatar image

gouchout
211
accept rate: 0%

I wouldn't recommend using fglrx (Now commonly known as Catalyst.) because it is grossly unreliable. If you switched to that driver and it isn't working for you chances it won't work for you no matter what you do, and I recommend switching back to open source drivers.

OR, if you want a GPU you can get all the potential out of under Linux, I strongly recommend nVidia cards. The proprietary driver is excellent quality. However, the open source drivers leave much to be desired. nv barely even supports 2D, and Nouveau is still years from completion and still doesn't have 3D acceleration.

link

answered 03 May '10, 16:36

Yaro%20Kasear's gravatar image

Yaro Kasear
4914
accept rate: 0%

Actually, the radeon driver (ATI nv equivalent) is quite well suited for 3d. i'm not sure it's available for all cards, but it worked great for my 9200, as long as i never moved windows with 3D graphics in them.

once it's fixed, try glxgears in a terminal and check the framerate. If it divides out to a frame rate that is pretty high (say 400 or higher FPS, not per 5 secs) you have a well-working 3d driver for your card, and you should leave it alone. fglrx is known to be buggy and unreliable, as is stated above.

The radeon driver does not work with extremely old agp cards, like my rage 128 pro, so watch for that.

link

answered 04 May '10, 03:05

William%20Shipely's gravatar image

William Shipely
661
accept rate: 16%

Thank you for all of your replies. I purged the fglrx from recovery mode and now the display booted up ok. The only gripe I have is that my monitor resolution is limited to 1028x768 an 1360x768 and 800x660 and 848x480 640x480. I know I could be using another resolution other than the present 1028x768. My card is capable of much more. By the way my card is a ATI-9600 all-in-Wonder. How would I be able to match what my card can actually can provide resolution wise? thanks again.

link

answered 04 May '10, 10:06

Michael%20Forsberg%201's gravatar image

Michael Fors...
1
accept rate: 0%

If you wish to reinstall fglrx do so, but after you install and when you reboot, go into recovery mode and use the command:

aticonfig --initial -f

This will force the ATI configuration to properly overwrite and set the correct xorg.conf values for the card. When you reboot now things should work. However, if you use a laptop you may have issues with ACPI so you can also try the command:

aticonfig --acpi-services=off

This will turn off the power saving features on the graphics which ATI did not implement properly in their drivers.

link

answered 11 May '10, 09:39

Gareth's gravatar image

Gareth
231115
accept rate: 62%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81

Asked: 03 May '10, 13:19

Seen: 2,901 times

Last updated: 20 Apr '11, 13:52

powered by OSQA