I am running XP and ubuntu 9.04 on a Dell Inspiron laptop. I have wi-fi access and ubuntu can see and connect with it. However none of the intenet applications (like Firefox) can see the net. What do I have to do to make these applications see and use the connection. The XP side works fine.

asked 03 May '10, 22:41

Bruce%20Morrison's gravatar image

Bruce Morrison
21113
accept rate: 0%

edited 07 May '10, 11:55

Web31337's gravatar image

Web31337
317111

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 13:45) rfelsburg ♦



The first thing is to make sure that you are really connected to the net. Try pinging Google. Then, just to be sure, you can use "echo -e 'GET / HTTP/1.0\n\n' | ncat www.google.com 80".

If that is working fine, you could try a packet sniffer like Wireshark to see where the information was trying to be sent. It could be a setting in your programs, but as it effects multiple programs I would think it is a system wide setting. Some things to check are your routing table and your firewall settings. It seems strange that you can connect to the internet, but applications can not. You may want to try some different applications, perhaps Lynx, to see if they are effected too.

link

answered 07 May '10, 07:10

kainosnous's gravatar image

kainosnous
3243
accept rate: 18%

1

more simply, /usr/bin/curl -sv 'http://www.google.com/'

(11 May '10, 20:48) memnoch_proxy

That's an unusual problem unless you tampered with Firefox's proxy settings. Try checking the proxy settings to see if anything other than the "use no proxy" or whatever is checked.

click edit > options > advanced > network > settings

and you should see the proxy settings from there

link

answered 04 May '10, 03:27

Jub's gravatar image

Jub
1362
accept rate: 14%

Pop a shell and try /sbin/ifconfig -a. Look for your wifi device (usually wlan0) and make sure you're getting an IP assigned. It will be around the second line for the relevant device and labeled by "inet addr". If you can't find this, then you haven't had an IP address assigned. Try dhclient wlan0 or dhcpcd wlan0 or whatever DHCP client to request one.

Try ping google.com. If it says "unknown host google.com" try host google.com. If these also fail then either your DNS server is set wrong or there's serious weirdness with your routing. Usually, DHCP should assign a DNS server automatically so it shouldn't be a problem.

Finally, try /sbin/route. There are two columns here we care about labeled Destination and Gateway. Find the row with a "default" Destination and get the matching Gateway. Try to ping this IP. (ping 192.168.0.1, for example)

Also check sudo iptables -L. It should look something like:

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

If not, say:
sudo iptables -P INPUT ACCEPT
sudo iptables -P OUTPUT ACCEPT
sudo iptables -F INPUT
sudo iptables -F OUTPUT

There are dozens of things that could be wrong, the results of these should point out the most common problems though.

link

answered 08 May '10, 02:32

hippiejake's gravatar image

hippiejake
111
accept rate: 0%

Many thanks for your help. Bruce

(18 May '10, 21:56) Bruce Morrison
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8

Asked: 03 May '10, 22:41

Seen: 14,093 times

Last updated: 20 Apr '11, 13:45

powered by OSQA