What distros support reading and writing to DVDs formated UDF/DLA under Windows?

asked 04 May '10, 22:46

otropogo's gravatar image

otropogo
1123
accept rate: 0%

Please accept an answer, or provide more details so we can help.

(14 Jun '11, 11:41) rfelsburg ♦



A few days ago Puppy 5 was released, using a recent Linux kernel that, if the response above is correct, should natively support UDF. If that's true, then the issue is not of UDF, but of support for DVD-RAM.

I tested three brands of DVD-RAM disks, 3x and 5x, both blank and formated and written to (by SLAX 6.1.2) in UDF 1.5 format. Puppy 5 was unable to mount any of the disks, and its chief burn utility Pburn appears equally unable to do anything with a blank DVD-RAM disk.

I'd love to try this with a DV-RW disk formated to UDF, however, I haven't been able to reliably use such a disk interchangeably in Windows and SLAX, so it would be a fairly futile exercise.

link
This answer is marked "community wiki".

answered 19 May '10, 15:34

otropogo%204's gravatar image

otropogo 4
11
accept rate: 100%

UDF is a linux-specific, it's a kernel feature to support UDF. And it should be enabled in most distros by default.

Though I never heard of or used dla before.

What errors do you get when mounting disc and in what disto?

link

answered 05 May '10, 01:09

Web31337's gravatar image

Web31337
317111
accept rate: 11%

DLA is a proprietary software to allow writing of UDF above the 2.0 standard on systems that don't fully support that natively (say Windows XP or 2003).

Starting from kernel 2.6.26, Linux fully supports all versions of UDF, so simply make sure that you are using a recent distribution and you should be alright.

link

answered 12 May '10, 09:30

pmarini's gravatar image

pmarini
286216
accept rate: 28%

@ ed: sorry for the tardy response. Linux exchange failed to notify me of your reply, and I only learned of it from the weekly summary received today.

DLA is a format that was already available for Windows 98, providing basically the same functionality as UDF (I believe the acronym stands for "disk-like access"). As pmarini says, it is a proprietary format. However, I believe that Windows 7 can read DLA-formatted disks (can't double check right now, due to lack of system).

I use the current version of Puppy Linux (4.3.1?) mostly, and I use DLA or UDF only on DVD-RAM disks. When I try to read a UDF formatted DVD-RAM disk in Puppy, I get a red pop-up that says "unable to mount sr0", while Puppy's mount utility, Pmount, shows the following (mis)information:

458GB 1 track when I have it's "use MUT" box checked in preferences

When the MUT option is unchecked, it shows the correct size of the disk at 4.3GB

The disk remains unmounted.

I should add, however, that this may be due to Puppy's inability to handle the DVD-RAM format, since I get the same response with an unformated DVD-RAM disk.

I occasionally use SLAX 6.1.2, and discovered by chance that it would read DVD-RAM disks formatted dla or udf. Further experimentation proved that DVD-RAM disks formated UDF 1.5 under Windows 7 could be read and written to under SLAX 6.1.2. However, DVD-RW disks formatted the same way caused both SLAX and Windows 7 to search the disk endlessly (after writing under SLAX). The default Windows 7 UDF format (2.01) also proved incompatible with SLAX.

I haven't tried other distros, due to the inability of most Live-CDs to run in memory and thus free the burner. However, will try to run a few tests in the next few days, now that I've found some interested correspondents. All previous responses have been that dla and UDF are simply not supported in Linux.

link

answered 12 May '10, 16:57

otropogo%202's gravatar image

otropogo 2
111
accept rate: 0%

Have done some more testing of DVD-RAM disks formated dla or udf. They're unreadable in both the current version of Puppy, and also in version 3.01 Retro, which uses Kernel 26.18.1. In the latter version, Pmount, the default mount utility will not mount the disks, however, MUT, the alternate utility mounts the disks but shows them as empty. I didn't try writing to them.

Under SLAX 6.1.2, the three DVD-RAM disks of different brands, speeds, and formats were all readable. Two were formated UDF 1.5 under Windows 7, one is a Panasonic 2.3X, the other a Verbatim 5X. Both showed up as "UDF" under storage media. Both have been written to successfully by both SLAX and Win7 in turn after formatting.

The third DVD-RAM disk is a Maxell DRM47 (2x or 3x, it's the oldest disk and came with my first LG burner some 5 or more years ago, and was formatted dla under Windows 98SE. It's listed simply by its label in the storage media window (no "UDF" or "DLA" indication). I haven't tried to write to it under SLAX or Win7, but it is readable under both systems.

link
This answer is marked "community wiki".

answered 14 May '10, 04:52

otropogo%203's gravatar image

otropogo 3
11
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6
×3
×2
×2

Asked: 04 May '10, 22:46

Seen: 5,435 times

Last updated: 14 Jun '11, 11:41

powered by OSQA