I have downloaded R tree from http://libspatialindex.github.com/

Since on running ./autogen.sh I was getting file/folder not found, therefore I downloaded the file autogen.sh from the github repository given below:

https://raw.github.com/libspatialindex/libspatialindex/9a5a2f4d83c3ec7be4dbf2c8a86341703d837185/autogen.sh

Now when I run ./autogen.sh I am getting "Permission denied" And if I run sh ./autogen.sh I am getting:

 glibtoolize or libtoolize not found. Giving up!

Please suggest what should I do now

asked 12 Feb '13, 16:18

isha's gravatar image

isha
111
accept rate: 0%




My first guess would be that "Permission denied" error happens because your not allowed to run ./autogen.sh So, to fix your problem, you would need to run "chmod u+x autogen.sh" to change the file permissions and allow yourself to run it.

To illustrate, I created a small script called hi.sh and put it in my current working directory. Notice the x in "-rwxr--r--" below.


$ ls -l

-rw-r--r-- 1 Tom None 25 Feb 28 22:44 hi.sh

$ ./hi.sh

-bash: ./hi.sh: Permission denied

$ chmod u+x hi.sh
$ ls -l

-rwxr--r-- 1 Tom None 25 Feb 28 22:44 hi.sh

$ ./hi.sh

Hello

$

link

answered 01 Mar '13, 00:59

bogonetic's gravatar image

bogonetic
212
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×90
×81

Asked: 12 Feb '13, 16:18

Seen: 4,626 times

Last updated: 01 Mar '13, 00:59

powered by OSQA