Have windows Vista and Ubuntu 10.04 on SAME hard drive in a Gateway T-1620 laptop, Vista uses Wifi but in Ubuntu it Fails and states message "Wireless is Disabled" Mt question is "How do I enable IT {wifi}. 60 year old Linux Newbie w/Experience looking for Answer

asked 05 May '10, 16:55

kICKSTARTBUBBA's gravatar image

kICKSTARTBUBBA
11112
accept rate: 0%

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 13:58) rfelsburg ♦



12next »

Ok this could be a couple of things.

  • Do not have the necessary Firmware Installed common with broadcom based wireless cards.
  • NetworkManager has disabled Wireless/Networking
  • Bios Switch i.e FN-f8 or similiar

  • Probably a couple more I don't remember.

If it is a firmware issue in Ubuntu run Hardware Drivers from the system menu or jockey-gtk from alt-f2 (Kubuntu jockey-kde or jockey-text if you are commandline only) you will be able to install the needed drivers or firmware for your wireless card if they aren't builtin you will need to have a internet connection to do this. A simple ethernet (LAN) connection to your router will work.

How it tell if networkmanager as disables Networking or Wireless Networking. Right click on you network icon (should be around the top right of your screen unless you made changes) there will be able menu that pops up at the top of it are checkboxes to enable Networking and Wireless make sure both are checked.

The other issues seem to be covered well in other answers.

link

answered 06 May '10, 19:23

verbalshadow's gravatar image

verbalshadow
363
accept rate: 100%

It sounds like your Ubuntu installation doesn't have the required drivers for your wireless card. Try running lspci.

You'll get output like the below but one of which will be your wireless card, you can then google for instructions to get it working on Ubuntu.

02:00.0 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB
02:01.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
02:02.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)
02:03.0 USB Controller: VMware Inc Abstract USB2 EHCI Controller

Assuming you can get it online using the Ethernet then you can probably use apt-get to install a proprietary driver (you may need to add a repository first though).

link

answered 05 May '10, 18:00

gregularexpressions's gravatar image

gregularexpr...
197117
accept rate: 50%

This might be silly, but I was having the same problem all week on a Dell Inspiron 6000. I keep thinking it was a "Restricted Drivers" problem (a la this thread - which fixed my other machine's problem).

In fact, it turned out that all I had to do was toggle the laptop's built-in Wireless "on-off" switch. On my Dell, that's FN-F2. I knew of, but had never used in 5+ years, that hardware toggle. It showed up in one of the Ubuntu logs as "killswitch enabled."

If you're a big-time newbie to laptop hardware, look for some sort of wireless icon over your Function keys. I mentioned my Dell's setting; on a Toshiba I have handy, the same toggle is FN-F8.

Hey, it's not ALWAYS a complicated driver problem! (:

link

answered 05 May '10, 19:10

Rich's gravatar image

Rich
111
accept rate: 0%

This happened to me too! I had the wireless working on my netbook with ubuntu jaunty and one day it stopped working. It took a day or two to figure it out.

(18 May '10, 12:06) Troy

Because there is a variance in the pci cards being used you need to do a lspci (first letter is an L) and look for the network card report. You most likely have a Broadcom wireless. Open the Synaptic Package Manager and using the search (binoculars) search on "wireless" and you should find a pair of Broadcom drivers. Install these and reboot your laptop and you should be in good shape.

I guess because of the variance they don't include these with the Ubuntu-restricted-extras.

link

answered 05 May '10, 22:25

FewClues's gravatar image

FewClues
24927
accept rate: 5%

ALL of the advice above is valid and good. I would just like to toss in this tidbit into the mix: Checkout ndiswrapper as that may be part of the solution too.

link

answered 12 May '10, 15:08

Ron's gravatar image

Ron ♦
936217
accept rate: 13%

Some step by step instructions here

http://wombatdiet.net/2010/05/09/ubuntu-10-04-on-asus-1000-eee-pc/

MAY be relevant, depending on the wireless hardware.

link

answered 12 May '10, 17:15

PJO's gravatar image

PJO
411
accept rate: 0%

Open the Synaptic package manager (admin menu) and enter "wireless" in the search. You will see several broadcom drivers. Install them all. Reboot the computer and try again.

link

answered 14 May '10, 04:46

FewClues's gravatar image

FewClues
24927
accept rate: 5%

This just came up for me today on my Gateway T-1620. The wireless has been working fine with stock Ubuntu installs for the last couple of years. Today it just didn't want to come up.

It turned out instead of the hardware on/off wireless switch, the "software" switch must have been turned off. Hitting Fn-F2 turned it back on, but I had to issue a dmesg command in the terminal in order to see what state it was actually in. There don't seem to be any graphical indicators of this problem.

The Realtek wireless card for this laptop only shows up when you do a lsusb command, not a lspci.

link

answered 20 May '10, 17:24

Choach's gravatar image

Choach
111
accept rate: 0%

Try here its from the support site at ubuntu

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

link

answered 23 May '10, 12:46

some%20dude%20in%20a%20coat's gravatar image

some dude in...
111
accept rate: 0%

When I had issues with Wireless on my laptop, I followed lots of tutorials from various parts of the internet to no avail.

I can't remember why but I had to install some of the ia32 libs, which provided my 64 bit Debian install with access to 32 bit libraries. I have ia32-libs, ia32-libs-gtk and ia32-libs-tools installed (Ubuntu may call them something different) and one of them enables wireless (or probably more precisely lets the wireless drivers work).

You never know, it may be something simple like this.

link

answered 24 May '10, 22:18

Amos's gravatar image

Amos
1321312
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×11
×8
×6

Asked: 05 May '10, 16:55

Seen: 16,884 times

Last updated: 24 May '11, 21:38

powered by OSQA