I'm trying to upgrade my Kubuntu version; but I can't get update-notifier-kde to run. Any one know how to fix this?

[LiquidDeath@Hydross ~]$ update-notifier-kde -d
Traceback (most recent call last):
  File "/usr/bin/update-notifier-kde", line 26, in 
    from PyQt4.QtCore import *
RuntimeError: the sip module implements API v6.0 but the PyQt4.QtCore module requires API v3.8
[LiquidDeath@Hydross ~]$ python
Python 2.6.2 (release26-maint, Apr 19 2009, 01:56:41)
[GCC 4.3.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from PyQt4.QtCore import *
Traceback (most recent call last):
  File "", line 1, in 
RuntimeError: the sip module implements API v6.0 but the PyQt4.QtCore module requires API v3.8

asked 05 May '10, 19:42

LiquidDeath's gravatar image

LiquidDeath
112
accept rate: 0%

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 13:58) rfelsburg ♦



Working backward -- Python 2.6.2 is required, also gcc4.3.3 before that. However, it appears the notification wants a downgrade!

Go to

https://help.ubuntu.com/community/FromUbuntuToKubuntu

and follow instructions, my friend.

link

answered 09 May '10, 03:16

hilyard's gravatar image

hilyard
912
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81
×4

Asked: 05 May '10, 19:42

Seen: 1,806 times

Last updated: 20 Apr '11, 13:58

powered by OSQA