Hello everyone, I have a very peculiar problem regarding the internet connection while downloading torrents. Before you conclude that I should "reduce the # of half-open & user connections", let me say I have done that.(10 half open connections, 20 users, it still doesn't work , and I don't get any downloading going on anymore).

I should also say that QoS shouldn't be necessary. usually in my experience with downloading torrents (in linux/windows nad mac) the internet connection was shared among all processes. Here it seems like torrents are chewing on all the available bandwidth. (Shouldn't the kernel be divide time among processes that request to send/receive packages?)

Finally, I should say that this problem started appearing after I updated to slack 64bit v14 (from v13.37).

So, the actual problem seems to be related with dns server not responding once I start download with ktorrent or rtorrent. And no webpages load anymore. torrent will be downloading at reasonable speed, but no websites will be loading. so "nslookup" and "dig" will tell me that the dns server (which btw is located on the same pc) was not found :

nslookup facebook.com
;; connection timed out; no servers could be reached

and

nass@stargaze:~$ dig !$
dig facebook.com
; <<>> DiG 9.9.1-P3 <<>> facebook.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 26154
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;facebook.com.                  IN      A

;; Query time: 1125 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Aug  2 01:14:46 2013
;; MSG SIZE  rcvd: 41

restarting the dns server (bind) while the torrent is running will generally NOT fix things, even though sometimes I have seen this happening. stopping the dns , deleting any .jnl files that were generated and restarting seems to work, but again it may not be always.( I don't have a repeated pattern for this case). I can't say I have found "a way" to get the internet back. -usually closing ktorrent and waiting for a few secs could even fix the internet on its own. -Other times closing the ktorrent client and restarting dns server would work faster than the previous case. -sometimes repeated restarts would NOT get the dns back working (bu waiting for a few mins would fix the prob) -recently I have started stopping named, deleting .jnl files and restarting it. This has had 100% success in my (only 2) trials.

the firewall log, the /var/log/messages/ and named's logs, doesn't register anything weird.

I am not keen in the use of tcpdump, wireshark, netstat so I don't know if I can use this tools to identify ...something! Could anyone help with this?

Since this problem seems to be related -primarily- to the dns server, I am appending my dns file and explain my pc's configuration abit. so ADSL internet arrive in the modem (provided by ISP, always on, even when I dont have internet) modem is connected to this pc where I am downloading torrents at eth1. this pc is network and file server (and my desktop when I am away). It is running iptables, dns, & squid servers (among others). Then from eth0 of this pc, the wifi and intranet switch is fed. The squid is running on a transparent configuration but it shouldn't both with torrent traffic as this is done on different ports (rather than the port 80)

So initially I am attaching my named.conf, in an attempt to get feedback on it (perhaps some logically erroneous config that is not caught from the webmin named config file checker - with which I have repeatedly verified that the named.conf file is syntactically correct)

named.conf is in here

If this is fine, is there someway I could start using tcpdump (and any other tool) under your guidance to collect info as to what might be causing this?

Thank you extremely much for your help :)

asked 01 Aug '13, 19:03

synthnassizer's gravatar image

synthnassizer
1313
accept rate: 100%




It's not unusual to find various bugs after any update. Did you do a fresh install or upgrade from an older version. It's just an opinion but I have never had any good come from upgrading as opposed to just wiping the older version and installing the newer. I keep my home directory on a separate partition so that my documents won't be affected. If everything is on a single partition, then a backup needs to be made before anything is installed.

Looking at the Slackware site, you apparently use ktorrent. If that is incorrect, let me know. Open it. Then go to: settings>Configure ktorrent>network

ktorrent has settings for maximum upload and download speeds in Kilobytes (as opposed to kilobits) You could try setting the maximum of each at about half of what your connection speed is as a start.

To verify what your actual connection speed is, close ktorrent and go to speedtest.net and run it two or three times, to get a real average of what you connection is capable of.

As an example, at speedtest.net, my connection shows 8Mbs per second (800 Kilobytes) download and 1.2Mbs per second (120 Kilobytes) upload. So in my case I would set ktorrent to max at 400 Kilobytes down and 60 Kilobytes up.

link

answered 02 Aug '13, 10:16

purevw's gravatar image

purevw
261
accept rate: 4%

Hi there, I use ktorrent and rtorrent. I tried setting the upload limit to smth ridiculously low (5kb/s) and it seems to be working now.... i'll do some more tests.

(02 Aug '13, 10:29) synthnassizer

ok so UL is at 5kbps and DL is 400kbps.. I still get to lose the internet connection..even though it seems to have vastly improved...

(02 Aug '13, 10:44) synthnassizer

The download speed should be the focus. You might try setting it to 300 or even 200 and see if that causes improvement.

(02 Aug '13, 11:14) purevw

ok well with 5.6Mbps DL , and 0.61 UL, it is entirely possible I have to reduce the limits for torrents considerably. but it seems this is enough on its own to improve the situation. Thank you for your help!

(02 Aug '13, 11:34) synthnassizer

well, i am at a location with far slower internet connection. with another pc, and downloading a torrent. How do you explain that without an intervention (limiting UL/DL) on my part, i can download torrents AND be able to surf in the meantime?

(04 Aug '13, 18:24) synthnassizer

I don't think the kernel will help with sharing bandwidth between processes. I have used "downthemall" as a Firefox plugin for years. In the past, any time I would start a download, the browser would take forever to load pages, assuming it could load them at all. The plugin was downloading at maximum available speed and would not allow the browser to load pages. It even affected my ability to just check e-mail. I e-mailed the author of Downthemall and asked for some kind of throttling control. It was done on the next update and all is well. I believe each program needs it's own pre-set limits. What torrent program do you use? I believe that ktorrent has the ability to limit overall bandwidth consumption somewhere in it's settings. Limiting the number of connections may not help since half the connections might operate at twice the speed per connection, thus using the same bandwidth as before the change. If you have a way to check your connection speed during a torrent download, is it near the maximum for your connection?

link

answered 01 Aug '13, 20:34

purevw's gravatar image

purevw
261
accept rate: 4%

how should I check about that? The point is I used to be able to max out my download speed and still have surf bandwidth... now no...

(02 Aug '13, 07:39) synthnassizer

You said it's a different PC? Different hardware? Router? Differrent ISP? Different encryption settings? Different ethernet and / or wifi card with different driver. Who knows?

Many ISPs limit connectivity when they see torrent downloads. I would have no idea if that could be part of the problem.

link

answered 04 Aug '13, 19:26

purevw's gravatar image

purevw
261
accept rate: 4%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×12

Asked: 01 Aug '13, 19:03

Seen: 9,474 times

Last updated: 04 Aug '13, 19:26

powered by OSQA