Dear Linux Exchange,

I was wondering if you guys have noticed the the graphics on the linux version of the game are rather disappointing compared to the windows version of the game?

If you guys know a way to fix it it would be much appreciated!

asked 05 May '10, 20:58

mag1strate's gravatar image

mag1strate
313
accept rate: 0%




This is assuming you have working drivers and all..

The Doom3/Quake4 engine has trouble detecting video memory. If it doesn't know, it will assume 64MB video memory by default. As a result you will get very bad textures, low quality per-pixel lighting, etcetera.

Edit your ~/.quake4/q4base/Quake4Config.cfg file. Check the following lines. The settings below are for my ATI Radeon HD 4800 with 512 MB memory:

seta com_videoRam "512"
seta image_downSizeLimit "1024"
seta image_ignoreHighQuality "0"
seta image_downSizeBumpLimit "1024"
seta image_downSizeSpecularLimit "512"
seta image_downSizeBump "1"
seta image_downSizeSpecular "1"

Edit these setting as appropriate. Restart. You should have gorgeous graphics now.

link

answered 09 May '10, 19:52

Sander%20Marechal's gravatar image

Sander Marechal
398116
accept rate: 29%

Check your PC meets the minimum requirements for the game.

  • GNU/Linux system
  • Pentium(r) 4 2.0 GHz or Athlon(tm) XP 2000+ processor
  • 512MB RAM
  • Kernel 2.4, 2.6 is recommended
  • glibc >= 2.2.4

3D acceleration ( not required for dedicated server ): - SDL >= 1.2 - latest OpenGL drivers, correctly configured - ATI(r) Radeon(r) 9700 - ATI Radeon 9800 - ATI Radeon X300 series - ATI Radeon X550 series - ATI Radeon X600 series - ATI Radeon X700 series - ATI Radeon X800 series - ATI Radeon X850 series - Nvidia(r) GeForce(TM) 3/Ti series - Nvidia GeForce 4/Ti series - Nvidia GeForce FX series - Nvidia GeForce 6 series - Nvidia GeForce 7 series

If you have Compiz or any desktop effects make sure they are turned off. Also try turning off force ambient light.

link

answered 07 May '10, 06:11

TracerBullet's gravatar image

TracerBullet
17817
accept rate: 44%

You also want to make sure that you're running the appropriate drivers for your video card. The open source drivers included with your distrobutions typically won't cut it for gaming.

Make sure you've installed the proprietary (restricted) driver appropriate for your video card.

Both AMD/ATi and Nvidia need to use the proprietary drivers quite often.

link

answered 07 May '10, 06:16

Pack3tg0st's gravatar image

Pack3tg0st
113
accept rate: 0%

-1

Install windows 7 and then just play the game.

link

answered 05 Oct '10, 20:20

Pack3tg0st%201's gravatar image

Pack3tg0st 1
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×90

Asked: 05 May '10, 20:58

Seen: 8,664 times

Last updated: 05 Oct '10, 20:20

powered by OSQA