I've upgraded many of the packages on my system using Synaptic, which upgraded various components including the kernel and KDE4. As a result I now no longer have audio.

uname -a gives me:

Linux alchemist 2.6.32-trunk-amd64 #1 SMP Sun Jan 10 22:40:40 UTC 2010 x86_64 GNU/Linux

lspci -vv gives me:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
    Subsystem: Acer Incorporated [ALI] Device 011e
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 22
    Region 0: Memory at 98400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel

KDE is on version 4.4.3

I don't have PulseAudio installed.

Alsa is on version 1.0.21

Using KDE's Settings tool for audio I've tried both the Xine and GStreamer backends, which give me options of outputting to either HDA Intel (ALC268) or to Jack. Neither option works.

Running alsactl init both as root and as the normal user gives me the following error:

Unknown hardware: "HDA-Intel" "Realtek ALC268" "HDA:10ec0268,1025011e,00100003  HDA:14f12c06,1025011e,00100000" "0x1025" "0x011e"
Hardware is initialized using a guess method

I'm fairly experienced as a Linux user, but I haven't had to reconfigure my sound since I moved from Slackware to Ubuntu 6 04, 4 years ago, and I don't think I've done a kernel recompile since then either.

The machine in question is my Acer Aspire 5720 Laptop. sound was working perfectly prior to the upgrade, Google has given me various ideas but none of them have worked yet.

EDIT I've tried the following:

  • Switching between the different backends.

  • I've also tried adding the line "options snd-hda-intel index=0 model=72" to the bottom of alsa-base.conf as suggested on one of the pages I went to, but it appears to have no effect.

  • I tried installing PulseAudio, but no combination of PulseAudio and other settings worked.

EDIT2 Right, I've got it partially working, by following olejorgenb's steps:

  • Unload all processes using the soundcard.

  • Change to the directory where the file called vendor_name contains Realtek (on mine it's at /sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D0)

  • then as root do echo acer > modelname && echo 1 > reconfig

Restarting kmix then lets me unmute the sound and it works.

But how can I make this change stick?

EDIT3 As per olejorgenb's suggestion I've tried adding:

echo acer > "/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D0/modelname"
echo 1 > "/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D0/reconfig"
/usr/sbin/alsactl init

to /etc/rc.local which didn't work. Then I tried putting it in /etc/init.d/speech-dispatcher as this is one of the processes I have to kill to get sound working manually. I see the usual message about

Unknown hardware: "HDA-Intel" "Realtek ALC268" "HDA:10ec0268,1025011e,00100003  HDA:14f12c06,1025011e,00100000" "0x1025" "0x011e"
Hardware is initialized using a guess method

scroll past during startup, but still no sound.

Anymore suggestions from anyone, how to get my sound to come up automagically on startup?

SOLUTION: It turns out that the above was a red herring, the problem lay with the fact that I wasn't a member of the audio group (or possibly pulse or pulse-access) adding myself to this group, and logging back in (I may have been able to bypass the login but I wanted to make sure) restored working sound to my system.

Have the requirements for either the kernel or Alsa changed so that to make audio work, you now need to be a member of the audio group. Or have Debian made changes? Or did the update change my membership?

Depending on which of these is probably the cause, depends where I submit a bug to.

Thanks for all of your help.

asked 06 May '10, 11:13

Amos's gravatar image

Amos
1321312
accept rate: 0%

edited 15 Jun '10, 09:09

I'd send a email to the one of the alsa mailing lists. http://www.alsa-project.org/main/index.php/Mailing-lists I guess alsa-user is the most appropriate?

I Still think you should report this as a bug to :) https://bugtrack.alsa-project.org/alsa-bug

(10 May '10, 01:11) olejorgenb

You don't need to edit the question title with "SOLVED", just accept the correct answer (as you did) and it's marked as solved.

(11 May '10, 07:13) guerda

I know that's how it works on StackOverflow etc, but if you look at the list of questions here (by clicking on the banner above for instance) then you will see that none of them have any indication of whether a question has an accepted answer or not. Either that functionality is missing from the version of StackExchange being used for LinuExchange or that part of the style sheet does not differentiate between them. There is also no idication of questions with 0 answers for instance. When that comes I'll re-edit the title to remove the SOLVED statement. Cheers.

(11 May '10, 09:58) Amos

Now that the site's formatting has been changed removed [SOLVED] from title.

(15 Jun '10, 09:10) Amos



Are you a member of the audio group?

Look at /etc/group for a line like:

audio:x:29:youruseridshouldbehere

If it's

audio:x:29:

Then that might be an easy fix!

link

answered 10 May '10, 04:09

pcardout's gravatar image

pcardout
226139
accept rate: 46%

I'm guessing I am since it works once I've gone through the steps above, but I'll check later.

(10 May '10, 05:35) Amos

I shouldn't be so quick to jump to conclusions. I added myself to the audio, pulse and pulse-access groups (I added the last two to be on the safe side) and all of a sudden it works. Have Debian or Alsa made changes and created an error in the updates? Or does the newest version require me to be in a group that previous versions didn't? I'm changing my accepted answer to this one as it's cured the problem.

(10 May '10, 08:44) Amos

outstanding! such a simple thing is forgotten :)) great, pcardout!

(10 May '10, 09:40) Web31337

That /etc/group check has gotten me out of several intractable problems over the years. Always nice when it's an easy fix!

(11 May '10, 05:35) pcardout

Somewhere in the upgrade my group memberships appear to have been altered, as checking my desktop on which I've not run a recent upgrade shows me as a member of audio.

(11 May '10, 10:33) Amos

I'm just throwing out something here:

First off you could try playing around with http://www.alsa-project.org/main/index.php/HDA_Analyzer

Or:

  • Go to /sys/devices

  • Find the folder containing vendor_name with content Realtek. (probably pciXXX/xx/xx/hwC0D0)

  • $ echo $MODELNAME > modelname && echo 1 > reconfig

If you get echo: write error: device or resource busy, make sure all audio apps is closed. Try different stuff for MODELNAME. Since you have a Realtek ALC268, try some of these: (from $KERNELSOURCE/Documentation/sound/alsa/HD-Audio-Models.txt)

ALC267/268
  quanta-il1        Quanta IL1 mini-notebook
  3stack            3-stack model
  toshiba           Toshiba A205
  acer              Acer laptops
  acer-dmic Acer    laptops with digital-mic
  acer-aspire       Acer Aspire One
  dell              Dell OEM laptops (Vostro 1200)
  zepto             Zepto laptops
  test      for testing/debugging purpose, almost all controls can
                    adjusted.  Appearing only when compiled with
                    $CONFIG_SND_DEBUG=y
  auto      auto-config reading BIOS (default)
  generic

I'd try test and generic first

I take in now way responsibility for what this might do. (You might have to reboot a couple times)

link

answered 06 May '10, 22:12

olejorgenb's gravatar image

olejorgenb
614
accept rate: 33%

edited 06 May '10, 22:31

I've tried echo-ing to the modelname etc, but even logging out and doing it from the command line I still get a write error: device or resource busy.

(07 May '10, 11:51) Amos

Try $ alsa unload as root. It should tell you the "offending" pid(s)

(07 May '10, 13:05) olejorgenb

Brilliant, that's got it (although I struggled first time through as I'd actually done alsa unload and the device disappeared). Now how do I make it so i don't have to go through this rigmarole after every restart?

(07 May '10, 13:46) Amos

What exactly worked? unload and changing to one of the modelnames above? Either way you should probably file a bug report, and in the mean time add the fix to rc.local or something I guess. It can probably be fixed by rebuilding alsa with the right config too, but that can be a pain in my experience.

(07 May '10, 13:52) olejorgenb

I've edited the OP with what I've tried recently, still can't get this to stick.

(09 May '10, 15:18) Amos

What have you tried so far? alsaconf didn't help? Did you try to rebuild alsa from source?

link

answered 06 May '10, 12:33

Web31337's gravatar image

Web31337
317111
accept rate: 11%

alsaconf doesn't appear to be installed (it's not in the path). I haven't tried rebuilding alsa from source yet as I was hoping there would be some glaringly obvious box which needed ticking/unticking.

(06 May '10, 13:04) Amos

As stated I've tried switching between the different backends. I've also tried adding the line "options snd-hda-intel index=0 model=72" to the bottom of alsa-base.conf as suggested on one of hte pages I went to, but it appears to have no effect. I tried installing PulseAudio, but no combination of PulseAudio and other settings worked.

(06 May '10, 13:43) Amos

if that worked before, i think you still have option to build it from sources, proven way that works :) I've just fixed similar issue when upgraded kernel in debian lenny. Last time I built alsa from source and it failed to work on boot of new kernel. I had to rebuild alsa. I did that first time because debian's default drivers had bugs: sound was corrupt. Sound refused to work at all after upgrade so I had no choice :D

(06 May '10, 15:18) Web31337

I'll give it a go in a bit. Is it just ./ configure, make, make install or have they made it overly complicated? Is alsa in its' own deb (with a related alsa-dev package) or is that too easy?

(07 May '10, 06:57) Amos

Can you point me to a good guide to recompiling Alsa, without recompiling the kernel, as I've just been looking and it doesn't appear the most straightforward of processes.

(07 May '10, 12:09) Amos

Hi, I had the same problems (Debian 6 Squeeze), my soundcard was working one moment and then on the next boot it just would not work, no matter what I tried, interestingly the Orca screen reader worked. I (Googled) the solution and found this page, lucky for me Im a noob and was struggling to install the alsa drivers etc & work out what to do, however the other day when I booted my system <fsck> was automatically forced to run by the system while booting (After 26 boots). When it had finnished and the login screen loaded I could tell that the sound was working again. And it is! Maybe you should try to force <fsck> to see if this works.

link

answered 30 Aug '11, 18:53

PurpleRabbit's gravatar image

PurpleRabbit
1
accept rate: 0%

edited 30 Aug '11, 18:56

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×23
×3
×2
×2
×1

Asked: 06 May '10, 11:13

Seen: 13,720 times

Last updated: 30 Aug '11, 18:56

powered by OSQA