What steps can you take to remedy the following problem- without wiping and restoring?

"Unable to mount XXXGB File System Error mounting: mount: Wrongfs Type, bad option, bad Superblock on /dev/sdb1

Missing Codepage or helper program, or other error In some cases useful info is found in Syslog - try dmesg/tail or SO"

Is this message too broad of a term to determine a specific problem?

asked 08 May '10, 14:28

Ron%20Stokes's gravatar image

Ron Stokes
11112
accept rate: 0%

edited 08 May '10, 14:33

Web31337's gravatar image

Web31337
317111

2

What is the actual filesystem on /dev/sdb1? what command did you use? what does syslog say?

(08 May '10, 14:33) Web31337
1

It's ext4 filesystem. As far as a command; I don't know what you mean- this happens on boot up. And how can I access a syslog if the system can't boot?

(08 May '10, 15:53) Ron Stokes

Please accept an answer, or provide more details so we can help.

(14 Jun '11, 11:37) rfelsburg ♦



Can you please confirm what filesystem you believe /dev/sdb1 should be? and also give us the output of the following command;

fdisk -l /dev/sda

Also is this removable media such as a usb pen drive? If so paste the output of "dmesg" as root when you plug the device in.

link

answered 08 May '10, 16:00

gjcwilliams's gravatar image

gjcwilliams
35729
accept rate: 37%

I have just seen your comment stating its an ext4 partition. What kernel are you using? Have you got a module loaded for ext4?

lsmod | grep ext

You could try booting a live cd and try mounting the disk from there.

(08 May '10, 16:04) gjcwilliams

Kernel 2.6.32.21 No Modules. This is the main HD. And it will not mount, using any live CD

(08 May '10, 17:57) Ron Stokes

Please pastebin syslog errors

(09 May '10, 15:58) Web31337

The partition might not correctly be recognised as ext4. It's possible that the system thinks it's ext2 or ext3. You might have to add a specific entry in /etc/fstab on the live system, or manually use the mount command specifying the type as ext4. This sounds obvious, but make sure you're using a recent live CD that supports ext4, as some don't.

(10 May '10, 08:36) Aronzak

Have you tried using puppy live cd, very useful for trouble-shooting issues such as yours,Ron.

link

answered 10 May '10, 02:51

1jnike's gravatar image

1jnike
961
accept rate: 8%

Mr. Stokes, I assume you know the role of /etc/fstab. If it does not agree with your drives/partitions or file system types, you will get errors on boot.
You are suggesting your system cannot boot, but what is interesting is that your error is on /dev/sdb. Your first hard drive is probably /dev/sda or /dev/hda, and that is likely the bootable one.

When you say you can't boot, you actually should say WHERE in the boot process it fails. Do you hang in the middle, or at the beginning?

Do you HAVE two drives? If the second one is messing up your boot, disconnect it for a while. Once you are booted, you can reconnect it and you have many more tools at your disposal. (You could probably even disable in BIOS and not have to mess with cables).

You ABSOLUTELY should be able to rescue your drive with a rescue CD (or a second bootable harddrive). Perhaps your superblock did get trashed ... the drive should be rescuable anyway, but you definitely want to boot on another drive. In fact, if you DON'T have two drives, you might want to put another one in just so you can get a full linux distro going from which to rescue your other drive.

If it IS a bad superblock, you can use a different one!

# dumpe2fs /dev/sdb2 | grep superblock

You can then take one of your alternate superblocks and use it in either fsck or mount.
Let's say you found an alternate superblock at 32768. Fsck first ...

# fsck -b 32768 /dev/sdb2

For more info -- see this excellent post: http://www.cyberciti.biz/faq/recover-bad-superblock-from-corrupted-partition/

link

answered 10 May '10, 04:24

pcardout's gravatar image

pcardout
226239
accept rate: 46%

edited 11 May '10, 05:55

Possibly you are using an older version of Linux

link

answered 08 May '10, 15:56

Iraj's gravatar image

Iraj
212
accept rate: 0%

Using Ubuntu 10.04. Apparently this happened on the upgrade from 9.10 to 10.04; and would not reboot!

(08 May '10, 16:12) Ron Stokes

Try reinstallation

(18 May '10, 20:01) Iraj

It seems to be missing something that it thought should be there. As the output says, you can try Syslog, or dmesg.

However, if it happens at boot time, then it is probably being mounted from fstab. Boot using a live CD. Then, open the fstab file to find the partitions that it is trying to mount. Try mounting them manually from the system you are booted into. To be extra sure, you can copy those lines from your old fstab into your new fstab, remembering to edit the mount points. Then, try mount -a. This is basically the way that the boot process mount extra partitions. There is the possibility that there are some bad options used in fstab.

link

answered 09 May '10, 10:08

kainosnous's gravatar image

kainosnous
3243
accept rate: 18%

Ron Stokes already said he tried livecds.

(09 May '10, 15:56) Web31337

That is very good as that is the obvious next step if the system does not on it's own. In fact, could you think of any other way?

(11 May '10, 02:52) kainosnous

when i mount file systm it hapen successfully mounted.......there r following step which is use by me 1.check fdisk -l /dev/sda.. 2.then make partition if i feel need ,method is -fdisk /dev/sda -use "n" for new -as for requirement use hard disk memory:-by enter cylinder size(for 200 mb-+200M) -use"w" for save it 3. use command PARTPROBE(which is necessary) 4.use mke2fs -j /dev/sda/(name of new partition-sda5) 5.make dir for mount=example-"/new") 6.then,"mount /dev/sda5(new one partition) /name of dir(example-"/new") 7.for check it ,use #mount command or "df -h" . . 8.for parmanentlly mount,go into fstab file system and entry dat partition. . ...............................above follow by me which is successfully mounted step.......

link

answered 09 May '10, 11:16

sumit%20chatterjee's gravatar image

sumit chatte...
1
accept rate: 0%

1) To determine which drives are mounted and what their device name is, aka sda, sdb1, and so forth, type: df -h

2) To unmount the hard drive, let’s say df –h said the drive was /dev/ sdb1, then: umount /dev/sdb1

3) To check the hard drive: e2fsck -D -f /dev/sdb1

4) To re-mount the hard drive after the check has completed: mount /dev/sdb1

Try that to fix the file system. Echoing eveyrthing said above, it could be something up with fstab, the kernel, etc.

link

answered 12 May '10, 15:14

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

the out put of fdisk -l /dev/sda command is

Cannot open /dev/sda

link

answered 22 Feb '13, 23:44

ilam's gravatar image

ilam
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3
×2

Asked: 08 May '10, 14:28

Seen: 11,516 times

Last updated: 22 Feb '13, 23:44

powered by OSQA