I recently purchased an HP Laserjet P1005 because it is about the best deal on the market for a fast personal laser printer. I am used to installing printers with little difficulty using

http://localhost:631

(This is the CUPS web interface).

When I plugged this printer in it was detected (checked dmesg and /var/log/syslog) and CUPS could see it as well. However, when I printed a test page, the job appeared, but never printed. I suspected bad hardware, but installed printer on a Windows system and (sigh) it worked just fine once I downloaded the driver from HP web-site. Where did I go wrong?

asked 10 May '10, 03:05

pcardout's gravatar image

pcardout
226239
accept rate: 46%

edited 29 Jan '11, 04:31




12next »

I DO have the answer to this question. It took me six hours of messing around, so I thought it was worth documenting. First:

Don't bother with the CUPS web interface. It is inadequate to the task for this printer. Begin with hp-setup. If you are using Debian Lenny or Ubuntu Karmic, you probably already have this program installed. If not, you can

apt-get install hplip

Which should install hp-setup and hp-check. Try

hp-check -r

.
It may throw errors, but will at least tell you that you have some of your drivers already installed (and where they are). Here is SOME of what I see when I run hp-check -r

Currently installed HPLIP version... HPLIP 2.8.6b currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file: [dirs]

run = /var/run

cupsbackend = /usr/lib/cups/backend

ppd = /usr/share/ppd/hpijs/HP

HERE IS THE BIG TRICK. Go here.

http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

You need to download TWO FILES.

hp_laserjet_1005_series.plugin

hplip-2.8.6b-plugin.run

The first file is what everyone needs (and should be adjusted for different printers). The second file depends on your version of hplip. How do you know? hp-check should have told you your version of hplip. Pick the appropriate .run file. Download both files to your /home or desktop.

Now run hp-setup. After selecting how your printer is attached, you are asked to select from discovered devices. My printer was discovered. If yours is not, you have a different problem than I. Next you are asked for a .ppd file. You are given the choice that the program will go out on the net and find a driver. Feel free to try it. It DID NOT work for me. You are also asked if you have the driver locally. The homework you just did pays off now. As I recall, the program allows you to specify a .run file first, and then a .plugin file. Use the files you just downloaded. After this -- IT JUST WORKS!

Since I DID mess around for six hours, there may have been things I did that you also need to do (If the above does not work). I mention some below. Before running hp-setup, as root, I copied my .plugin file to: /usr/share/hplip/plugins

I also have the following installed:

  • openprinting-ppds - OpenPrinting printer support - PostScript PPD files
  • hpijs-ppds - HP Linux Printing and Imaging - HPIJS PPD files
  • hpijs - HP Linux Printing and Imaging - gs IJS driver (hpijs)
  • hplip-data - HP Linux Printing and Imaging - data files
  • hplip-dbg - HP Linux Printing and Imaging - debugging information
  • hplip-doc - HP Linux Printing and Imaging - documentation
  • hplip-gui - HP Linux Printing and Imaging - GUI utilities hplip - (HPLIP)
  • gs - Transitional package

After I posted this answer, I got an official answer from Hewlett-Packard tech support. I thought it was worth including.

You can also download the Linux drivers from http://hplipopensource.com/hplip-web/install_wizard/index.html by following the instructions appropriately.

but I had already figured it out by then.

link
This answer is marked "community wiki".

answered 10 May '10, 04:04

pcardout's gravatar image

pcardout
226239
accept rate: 46%

edited 10 May '10, 21:25

Thanks, man. You saved me.

(10 May '10, 06:57) Vanco

Dear Vanco -- Glad I helped someone. It seemed clear to me that this printer has caused a lot of suffering on the net ... but it's such a pleasure when it works!
I do have two questions for you to improve my post,

1) Did you find that you already had hp-check and hp-setup installed as part of your distro?

2) What is your distro? Some Ubuntu/Debianish thing?

(10 May '10, 21:24) pcardout

Great job. I have one of these printers as well and it gave me a lot of problems. Thanks.

link

answered 13 May '10, 13:34

Wilson's gravatar image

Wilson
312
accept rate: 0%

Thanks for the good HOWTO

link

answered 15 Dec '10, 23:21

Oliver's gravatar image

Oliver
1
accept rate: 0%

Since posting, I changed from Debian to Ubuntu (karmic) on the same hardware I had when I wrote the OP. I think the procedure described above would also work on Ubuntu, for which hplip and hp-check are installed by default, but it does not seem necessary.

When I plugged the USB cable for this printer into my Ubuntu system, it was auto-detected and a box popped up telling me I had to download a special "restricted" driver from HP. Even though I knew what it was doing, had I been a total noob, I think it would have worked ... it was about two clicks. The install on Ubuntu was simpler and faster than the install on Windows Vista.

I can qualify this by saying that before I plugged in the printer, I ran hp-check and installed the several packages it told me I needed. It may be that had I not done that the auto-install would not have worked so smoothly. I would be interested in hearing from other Ubuntuans ... though you may not be looking here since you have no problems!

link

answered 03 Feb '11, 05:21

pcardout's gravatar image

pcardout
226239
accept rate: 46%

I am still the OP. pcardout and pcardout2 are the same guy ... I just can't figure out how I logged in originally.

While my original procedure is correct, it's all been messed up by the collapse of the openprinting.org website, which has now been down for several months. I went back to Hewlett-Packard, and they are now hosting the necessary "plugins". They do not seem to provide old versions, but if you upgrade to the latest HPLIP, they always have the plugin for that. Here is my correspondence with HP support.

Your question #177357 on HPLIP changed: https://answers.launchpad.net/hplip/+question/177357

Status: Open => Answered

Amarnath Chitumalla proposed the following answer: Hi xxxxx,

To use 3.11.10 plugin, needs upgrade HPLIP to 3.11.10 version. and 3.11.10 plugin will be automatically downloaded using following site when you run hp-setup command.

http://www.hplipopensource.com/hplip-web/plugin_download.html

I went to the link given above and downloaded the plugin. I then went back to the main HPLIP site and downloaded the latest .run file which installs HPLIP and followed those instructions.
While Mr. Chitumalla (HP support) suggested that hp-setup would automatically find the plugin, I did not assume that would work. I had already downloaded the plugin ... as above, and there is a "manual install from local copy" option on hp-setup. I chose that and gave it the plugin file. It all worked easily.

So for all those folks saying

where can I find hplip-3.11.7-plugin.run

or

openprinting.org down, where to get the hp-plugin

... this is the answer. HP has it... as they should! (It's just not very well documented!!!!)

link

answered 05 Nov '11, 13:58

pcardout2's gravatar image

pcardout2
112
accept rate: 0%

edited 05 Nov '11, 14:16

The model number HP Laserjet P1005.

Method 1: You may refer to the below links and use the troubleshooters. Check if it lists and helps resolve any issues: Open the Printer troubleshooter:

http://h10025.www1.hp.com/ewfrf/wc/product?product=3435676&lc=en&cc=us&dlc=en&task=&lang=en&cc=us

Method 2: You may check if you have the latest drivers installed for the device. You may refer to the below link for getting the latest drivers and check. HP Laserjet P1005 Driver

Good Luck.

link

answered 17 Mar '12, 09:43

calik's gravatar image

calik
111
accept rate: 0%

Ok, so I don't use Debian nor Ubuntu. I use Slackware. And I don't have an HP P1005. I have an HP P1006.

I use the software from this page http://foo2xqx.rkkda.com/

This requires me to download a tarball, untar it, compile and run a command. The command downloads a driver from the web. Then, I run some more commands and finally, eventually it works.

I've had this printer for a few years now. It works. Sometimes, I have to unplug/re-plug the USB cable. This is because the printer downloads some firmware (or something) when the USB connection is refreshed.

Firmware Not Downloaded:

usb_printerid /dev/usb/lp0

GET_DEVICE_ID string: MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS: PRINTER;DES:HP LaserJet 1020;

Firmware Downloaded:

usb_printerid /dev/usb/lp0

GET_DEVICE_ID string: MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS: PRINTER;DES:HP LaserJet 1020;FWVER:20050309;

The printer will only print when the firmware has been downloaded. Otherwise, it just sits there dumb.

There are some other printers from HP that require this same treatment. It's a pain.

I suspect that HP makes printers like this, because it's cheaper somehow.

This is probably not the explanation that anyone was looking for, but the page does explain something about why this kind of printer needs special handling.

I find it is a pain to have to look for versions of HPLIP and a bunch of dependencies when all I want to do, is print. The page will probably work for all distros that come with a compiler regardless of whether they come with apt-get, yum or another package handler.

link

answered 17 Apr '12, 06:24

Seth%20Brown's gravatar image

Seth Brown
111
accept rate: 0%

Hi I'm the OP (pcardout, pcardout2) I just upgraded a computer to Debian Squeeze. All my original instructions about hp-check and hp-setup and the .run and the .plugin files still work -- and are still necessary. Plain old CUPS did not do the job ... as before.

link

answered 16 May '12, 16:31

pcardout2's gravatar image

pcardout2
112
accept rate: 0%

Greetings again from the OP. I have now upggraded certain machines to Linux Mint (Olivia). When I did the Mint install, my printer was not already connected (if it were, perhaps Mint would have found it and set it up). Anyway there was no queue available for the laserjet P1005, so I tried hp-setup. (after running hp-check and allowing hp-doctor to do what it wanted ... though this may not have been necessary). I tried hp-setup, as a user (not as root). It just worked. These days the driver web-sites are working better. hp-setup found both the open-source and proprietary drivers for this printer and installed them. I then used the web interface of cups http://localhost:631 and the printer was already there, I just selected it as my default.

So this how-to is now down to one command, hp-setup.

Search Engine candy here: How do I install the hp laserjet p1005 under Linux Mint Olivia?

link

answered 22 Jan '14, 11:07

pcardout2's gravatar image

pcardout2
112
accept rate: 0%

edited 22 Jan '14, 11:08

link

answered 22 May '14, 00:29

Zhu%20Lyn's gravatar image

Zhu Lyn
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1
×1
×1
×1
×1

Asked: 10 May '10, 03:05

Seen: 29,101 times

Last updated: 08 May '15, 07:00

Related questions

powered by OSQA