I an using Ubuntu 10.04. I have decent hardware (2.6 Ghz Intel Core 2 Duo, 1GB Ram) However it takes a lot of time to boot. I tried booting through the recovery mode but i could not understand anything.

I have uploaded the boot log here http://pastebin.com/7DGS3u7h

asked 11 May '10, 05:19

Tapan%20Chugh's gravatar image

Tapan Chugh
7818
accept rate: 50%

edited 11 May '10, 05:44

guerda's gravatar image

guerda
5533515




To inspect your boot process, use bootchart. It records your boot process and creates a neat graphic, e.g. sth. like this:

Bootchart of the question poster
Larger

It works as a daemon and creates a bootchart every time you start your computer. You can optimize your boot process if you parallelize the processes.

Edit:
I inserted Tapan's bootchart. It's very freaky, imho.

link

answered 11 May '10, 05:48

guerda's gravatar image

guerda
5533515
accept rate: 38%

edited 17 May '10, 11:41

i have been able to log my bootprocess but i am not able to understand. I have uploaded the image http://yfrog.com/0otapandesktoplucid201005p. can you help me understand it.

(13 May '10, 07:55) Tapan Chugh

Thanks for the info. I added a new answer: http://linuxexchange.org/questions/453/#631

(17 May '10, 12:03) guerda

Looking at your boot log I noticed these two entries:

[    2.078263] usb 3-2: configuration #1 chosen from 1 choice
[   21.816069] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

So basically your boot sequence is going from 2 seconds to 22 seconds trying to load a drive. There are a few mentioned possible fixes you can try and the easiest one of these is ... put a disk in your CD/DVD drive and it might help.

There are other very hacky and hard to do fixes which will eventually be resolved. The potential problems relate to Samsung hard disks that have BIOS settings that cause the freeze and a few more.

link

answered 11 May '10, 09:14

Gareth's gravatar image

Gareth
231115
accept rate: 62%

In addition to switch off the unnecessary auto-start service via System>Accessories>Startup. You can make use of the duo core of your system by enabling parallel booting by following configuration:

  1. edit /etc/init.d/rc
  2. modify "CONCURRENCY=none" to "CONCURRENCY=startpar" (of course without quote)
link

answered 11 May '10, 07:21

abgalphabet's gravatar image

abgalphabet
211
accept rate: 0%

As I looked at your bootchart, I assume you should search for hardware problems.

kblockd and async are both processes for controlling I/O of block devices. Propably one of your block devices is corrupt and lets your linux stop booting.

The boot log shows similar hints:

[  106.005524] sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current]
[  106.005530] sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
[  106.005537] sr 0:0:1:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 02 00
[  106.005546] end_request: I/O error, dev sr0, sector 0

(Line 501 ff)

Line 445 shows, what sr0 is: A SCSI attached CD drive:

[   93.998132] sr0: scsi3-mmc drive: 16x/48x cd/rw xa/form2 cdda tray

Try the following:

  1. Detach your CD drive.
  2. Boot again.

Good luck!

link

answered 17 May '10, 11:43

guerda's gravatar image

guerda
5533515
accept rate: 38%

edited 17 May '10, 12:08

1

Are you sure. I have two cd drives and am able to use them both without any problem. I also have one hardisk on which i have ubuntu as well as windows XP.

(20 May '10, 05:57) Tapan Chugh

It's just a suspicion. It looks like your cd drive is stopping your boot process. Are your CD drives attached via SCSI?

(20 May '10, 06:38) guerda

In order to reduce start-up-time you can go to System>Accessories>Startup programs and unmark the daemons you do not need to load at default.

In order to reduce startup time I'd advice you to remove just one program at a time, then boot the computer. You'll have to know which programs you don't need at startup else you risk destroying your entire system.

Things such as Bluetooth, Gnome remote desktop and personal file sharing are things that is just there, things that you normally do not use.

link

answered 11 May '10, 06:35

Jimmyfd's gravatar image

Jimmyfd
212
accept rate: 0%

Consider checking your network settings. Your boot might be trying to do something so silly as to be hanging on acquiring a DHCP address or resolving a hostname.

I also suggest checking dmesg and/or /var/log/syslog to check for disk or memory problems. If you're using a spindle disk (not ssd) then you might be encountering a failing sector. Read up on the e2fsck -c option.

link

answered 11 May '10, 20:36

memnoch_proxy's gravatar image

memnoch_proxy
1413
accept rate: 42%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81
×13
×8

Asked: 11 May '10, 05:19

Seen: 4,293 times

Last updated: 17 May '10, 12:08

powered by OSQA