Dell Latitude C-610 has a DVD-ROM taen out of a C-640 and put into the C-610.

I had Ubuntu 9.10 on it and everything works just fine.

I reformatted, installed Ubuntu 10.04, everything works just fine.

I updated from 10.04 to the latest kernel and other updates, rebooted, now the icon shows as floppy0 and it won't read CDs or DVDs because it thinks it's a floppy drive, not a DVD-CD ROM drive.

I rebooted the system with a Live CD of 9.04 and it sees it as a DVD-CD ROM. I rebooted the system with a Live CD of 10.04LTS and it sees it as a DVD-CD ROM.

Therefore........

I have verified that:

1) The drive physicall works. 2) It's not the BIOS or anything to do with that. 3) It worked with Ubuntu 9.04 and 10.04LTS, but not after the updates for 10.04LTS

Therefore based upon the above information, I have determined that the most likely cause is an update to Ubuntu 10.04LTS.

Has anyone else experienced this issue? How may I fix it?

Ron

asked 11 May '10, 20:00

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

edited 08 Jul '10, 15:47

If you found a solution, please mark the question as solved. You can do this via accepting the best answer with the tick next to the answer. It gives the answering person reputation points and you too! So please accept the answer and you don't need to put "[SOLVED]" into the title.

(09 Jul '10, 08:27) guerda



  • Short way: backup your /home directory (unless you already have it on a separate partition), then re-install the whole OS again

  • Medium way: un-install the updates, there should be a view in the software package system that allows you to see what was installed and when, from there you should be able to revert to previous versions of packages that you had before the problem appeared

  • Long way: switch off the computer, unplug the DVD-ROM, start the computer, check what happens, if there still is a floppy0 device, it might come from another place or it might really be a bug in 10.04
link

answered 12 May '10, 09:19

pmarini's gravatar image

pmarini
286216
accept rate: 28%

Short way: Good idea, but invalid if the system is updated.

Medium way: Good idea, but invalid if the system is updated.

Long way: Did that and it still remains as a floppy drive when I boot off of the hard drive with Ubuntu 10.04LTS+updates installed on it. When I boot off of the live CD of Ubuntu 9.04 or 10.04LTS, the DVD drive appears and works as it should, thus I believe as stated above, that this is an issue with the Ubuntu updates.

In the end, I will most likely just need to submit a bug report in Launchpad.

(12 May '10, 14:50) Ron ♦

It now works. I just waited and then did some more updates, all good - for now.

(08 Jul '10, 15:46) Ron ♦

I'll submit a bug report to the developers via Launchpad as I believe this to be a flaw in one of the post-install Ubuntu 10.04LTS updates.

UPDATE - 06/03/10 - I just reformatted the laptop's hard drive > put on Ubuntu 10.04LTS (32-bit) Desktop Edition > did NOT download any updates > all is fine.

Issue resolved (for me at least).

Maybe I'll update when the first or second point release comes out.

link

answered 12 May '10, 14:52

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

edited 03 Jun '10, 15:20

Why do the Ubuntu people always screw up the floppy drive, it worked fine in 9.04 did not work in 9.10 ever and it did work in 10.04 but now it does not work. There must be someone with a net book on the development team that seems to leave floppy out. So again we have to take computers back to an older version and start looking for other LINUX that does not keep making floppy NOT WORK. For a while it was a good version until someone screwed it up!

link

answered 08 Jul '10, 06:42

Sam's gravatar image

Sam
1
accept rate: 0%

Well, after some updates, it now works. Frustrating? Yes... but it could be worse. There are some other distros out there that everything needs to be done from scratch and if there's a problem and you aren't a programmer/developer who can write their own fix, you're basically told to "STFU n00b!! Go away!!" Linux distros can be patched whereas attitudes unfortunately cannot be it seems.

(08 Jul '10, 15:35) Ron ♦

Yeah but it worked and no it does not work. So what do we all do go back to 9.04 because someone forgot about the millions of people who still use FLOPPY and want that functionality on their machines? So it is still broke in the 64 bit version.

link

answered 08 Jul '10, 20:38

steve's gravatar image

steve
1
accept rate: 0%

Someone figured out down in the Bayou This and it seems to work fine. "For those who may ask...go to synaptic, open it, & type in "udisks". The result will show you probably "udisks(1.0.1-1ubuntu1)". Select properties & go to versions header, select the "1build1" package & go back to package header & select "force version" option....proceed as usual & it will install. Go to places & click on the floppy & it should mount! I don't know if the floppy will have to be re-mounted each use or not, but it will be a "work-around", hope it won't be lost with upgrades...but may have to be vigilant... It works now. I suspect that one of the developers was thinking desktop and another was thinking netbook, so they left out a lot of functionality. Call it USB bias. Anyhow it works by taking it back.

link

answered 11 Jul '10, 07:25

Tom's gravatar image

Tom
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81
×6
×6
×5

Asked: 11 May '10, 20:00

Seen: 4,110 times

Last updated: 11 Jul '10, 07:25

powered by OSQA