Hi guys,

I have fedora 12 installed in VMWare ESX on a Dell Optiplex machine with a Intel GBit lan.

While transfering from fedora's vsftpd to my workstation trough a sitecom gbit switch i get a real bad performance, mostly not higher then 8mb/s. (btw on the same ESX i have Windows 2008 from wich i get around 60mb/s)

I have tried to set the eth0 to 1000Mb/s full duplex using ethtools but this fails (ethtool -s eth0 speed 1000 duplex full autoneg off). I keep recieving the following error:

 Cannot get current device settings: Operation not supported
  not setting speed
  not setting duplex
  not setting autoneg

When i try to view the eth0 information, using ethtools, i get this:

Settings for eth0:
        Current message level: 0x00000007 (7)
        Link detected: yes

In /etc/sysconfig/network-scripts/ifcfg-eth0 i've added this:

 ETHTOOL_OPTS="speed 1000 duplex full autoneg off"

But on starting the network service, i get the same "Cannot get current device settings: Operation not supported" error.

Using mii-tool eth0:

 SIOCGMIIPHY on 'eth0' failed: Operation not supported

lshw -class LAN result:

   *-network
       description: Ethernet interface
       product: 79c970 [PCnet32 LANCE]
       vendor: Advanced Micro Devices [AMD]
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 10
       serial: 00:0c:29:1d:75:b4
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master rom ethernet physical logical
       configuration: broadcast=yes driver=pcnet32 driverversion=1.35 ip=192.168.1.101 latency=64 link=yes maxlatency=255 mingnt=6 multicast=yes
       resources: irq:18 ioport:2000(size=128) memory:dc100000-dc10ffff(prefetchable)

Have i missed something? I've been searching for PCnet32 NIC drivers, but could not find any :(

asked 02 Jun '10, 08:04

Zarko%20RSK's gravatar image

Zarko RSK
1112
accept rate: 0%

a quick comment would be that to obtain a performance comparable to the 2008 one you could simply set the netcard to 100Mbit/s, unless by 60mb/s you actually mean 60Mbytes/s...

(02 Jun '10, 10:59) pmarini



You could try reading the "Network Performance Best Practices" section of this document http://www.vmware.com/pdf/vi_performance_tuning.pdf , as it mentions something about using vmxnet instead of vlance and that the "speed" set or indicated by the guest OS doesn't really mean much as it will still try to use the physical netcard maximum

link

answered 02 Jun '10, 11:11

pmarini's gravatar image

pmarini
286216
accept rate: 28%

thnx for your tip !

i think i have fixed it, this is what i did:

i have installed VMWare Tools

shutdown guest VM from the guest VM properties i removed the Network Adapter and added a new one. This time a E1000...

after adding this one, i booted and did a ethtools eth0 with this result:

Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: d
    Wake-on: d
    Current message level: 0x00000007 (7)
    Link detected: yes

i dont know if installing vmware tools did the trick, or changing the NIC to a E100

lshw -class LAN:
      *-network
       description: Ethernet interface
       product: 82545EM Gigabit Ethernet Controller (Copper)
       vendor: Intel Corporation
       physical id: 11
       bus info: pci@0000:00:11.0
       logical name: eth0
       version: 01
       serial: 00:0c:29:1d:75:b4
       size: 1GB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list rom ethernet physical logical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k5-NAPI duplex=full firmware=N/A ip=192.168.1.101 latency=0 link=yes mingnt=255 multicast=yes port=twisted pair speed=1GB/s
       resources: irq:18 memory:dc060000-dc07ffff memory:dc000000-dc00ffff ioport:1080(size=64) memory:40000000-4000ffff(prefetchable)

When i get home i'm gonna test the download speed i shure hope this is it...

link

answered 02 Jun '10, 12:42

Zarko%20RSK's gravatar image

Zarko RSK
1112
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2

Asked: 02 Jun '10, 08:04

Seen: 14,499 times

Last updated: 02 Jun '10, 12:42

powered by OSQA