I'm using Ubuntu 10.04 and I'm having problems with my wireless connection. It simply stops working randomly.

I thought the cause might be a number of connections or something like that, but it's not. Sometimes it stops working while you're off doing something unrelated to the network.

Also, once it stops working, I'm unable to connect anymore until I reboot the machine. Some say it might be a problem with NetworkManager, but I can't use the recommended wicd because it won't even connect (it seems like hidden SSID + wep bothers wicd).

I'd also like to note that I have a windows PC connected to the same router and it never drops a connection like that, so there's obviously nothing wrong with the router.

Any hints would be helpful. I'd like to drop NM altogether if possible, but I'm not aware of any good alternative.

Edit:

lecterror@feck:~$ lspci -nnk | grep -i net -A2
07:00.0 Network controller [0280]: Intel Corporation Wireless WiFi Link 5100 [8086:4232]
    Kernel driver in use: iwlagn
    Kernel modules: iwlagn
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5764M Gigabit Ethernet PCIe [14e4:1684] (rev 10)
    Kernel driver in use: tg3
    Kernel modules: tg3

lecterror@feck:~$ rfkill list
0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

sudo iwlist scan got me a large list of available networks, I'm assuming you don't need it if that's the expected output :)

Edit 2:

No dice! :( My "solution" in the answers below didn't work, in fact it made everything worse, disconnections every few seconds. dmesg said this:

[ 1170.188961] wlan0: deauthenticating from XXXXXX by local choice (reason=3)

I have no idea what it means, but it sure as hell wasn't by MY local choice!

For now I've reverted to NetworkManager and the funny thing is that is seems more stable than before(?). Possibly due to WEP->WPA switch, but I can't be sure..

Any ideas?

asked 09 Jun '10, 11:18

dr.%20Hannibal%20Lecter's gravatar image

dr. Hannibal...
1115
accept rate: 50%

edited 20 Jun '10, 09:58

Please add the tag ubuntu-10.04, thanks!

(09 Jun '10, 13:02) guerda

Unfortunately, your provided information is not sufficient to help you. Could you please add some log files? Output of dmesg?

(09 Jun '10, 13:03) guerda

Hm, sure I can, what do you need? I'm fairly new to Linux so I'll need some guidance :) Are you sure I need to add the lucid tag? This occured on both 9.10 and even 9.04 before that... :(

(09 Jun '10, 14:31) dr. Hannibal...

lspci -nnk | grep -i net -A2 # For PCMCIA cards lsusb # For USB cards rfkill list sudo iwlist scan

Please put all output in code tags (4 spaces in front of each line).

I thought the lucid tag is interesting, if you put "lucid lynx" in the title...

(09 Jun '10, 15:04) guerda

I will edit the question to add the output as soon as I'm able to (I'm at work right now, and the laptop in question is at home).

(09 Jun '10, 15:14) dr. Hannibal...

I have some problems when I am not broadcasting the SSID. Have you tried as an experiment broadcasting the SSID to see if the Lucid box exhibits the same behavior?

(10 Jun '10, 15:34) Andy
showing 5 of 6 show 1 more comments



It's been a while now, and the connection seems to be working reliably. The setup is as follows:

  • Switched network to WPA2-PSK
  • Broadcasting SSID is enabled
  • Switched back to NetworkManager

So, Andy's comment might have something to do with it (SSID)..or the WEP->WPA switch..or something completely different. I guess we'll never know..

In any case, @everyone: thanks for your effort!

link

answered 07 Jul '10, 21:19

dr.%20Hannibal%20Lecter's gravatar image

dr. Hannibal...
1115
accept rate: 50%

I have found this thread on Ubuntu forums and followed the instructions on the first two posts.

I have switched my network from WEP to WPA2-PSK (it's a good move anyway) and edited my /etc/network/interfaces to include the following:

auto wlan0
iface wlan0 inet static
address 192.168.0.10
gateway 192.168.0.1
dns-nameservers 83.139.105.2 83.139.104.2
netmask 255.255.255.0
wpa-driver wext
wpa-ssid {$MYESSID}
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP TKIP
wpa-group CCMP TKIP
wpa-key-mgmt WPA-PSK
wpa-psk {$MYPSK}

I have also removed both wicd and NetworkManager (this didn't work with either one of them running...for some reason).

It seems to be working for now, but I'll wait a week or so to see if it will happen again. If it doesn't I'll mark this as accepted, but if it does..feel free to post your solutions too :)

Edit: This did not work, results of this "experiment" have been added to the question.

link

answered 13 Jun '10, 12:20

dr.%20Hannibal%20Lecter's gravatar image

dr. Hannibal...
1115
accept rate: 50%

edited 20 Jun '10, 16:09

Do you have an Atheros wireless card by any chance? If yes it could be the ath5k driver sausing the problem. You could compile and install the madwifi driver to substitute for the defective ath5k driver. Another option is to upgrade to the latest 2.6.34 series kernel.

link

answered 11 Jun '10, 17:42

zorbix's gravatar image

zorbix
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×81
×23
×17
×11

Asked: 09 Jun '10, 11:18

Seen: 3,682 times

Last updated: 07 Jul '10, 21:19

powered by OSQA