i was configured the samba server in linux but i want to login as a samba user in windows XP machine how to do this?

asked 11 Jun '10, 19:51

Sureshrhce's gravatar image

Sureshrhce
112
accept rate: 0%

Please accept an answer, or provide more details on what you're looking for.

(14 Jun '11, 11:42) rfelsburg ♦



I mean this in the sincerest way without any malicious intent; but please check first for your answer via searching Google. I am all for helping people out, but there's quite the extensive database of help for certain distributions of Linux like Red hat, CentOS, Debian, Fedora, etc.

That being said, I found this (via Google at https://www.ccs.uky.edu/docs/samba.htm ) which may be of help to you.

First Setting up the Samba Server: 1) For setting up samba server configure smb.conf file which is usually found under /etc/samba/ directory.

Notes: After changing smb.conf always restart the samba server

Commands to be used: ./smbd stop ./smbd start

2) Changes to be done in the smb.conf file are Notes: a) Whenever you modify this file you should run the command "testparm" to check that you have not made any basic syntactic errors.
b) Read the smb.conf man page to understand the various parts of the file

In the Global section [global] the significant entries are:

[global] logon drive = p: // Here you can set the drive letter encrypt passwords = yes

/* To allow only specific hosts who can connect to server below entry is used make sure localhost is added */

hosts allow = IP-address, 127.0.0.1/255.255.255.0

logon home = \netbiosname\%U // home directories will be mounted as the user logs on.

passwd program = /usr/bin/passwd %u

wins support = yes //Enable the windows support dns proxy = no

netbios name = wealhtheow //Set the netbiosname

netbios aliases = rch01 //Set the alias, this is optional

unix password sync = No //Sync the unix passwords (Samba (actually 'smbd') makes use of the file 'smb.conf' to know about its configuration. During installation of samba, smb.conf is created in the directory '/etc/samba' by default. But in FreeBSD all the system configuration files are put in the directory /usr/local/etc/. There were two smb.conf files that were existing on this system and therefore a link was created from /etc/samba/smb.conf to the actual file used by FreeBSD which is /usr/local/etc/smb.conf. This was done to make sure that the Samba server uses the correct version of the configuration file. To resolve the passwords problem, the smb.conf file was modified to remove synchronization between the Samba and Unix passwords.)

logon path = \rch01\profiles\%U // This will tell the server where to place the home directories

workgroup = rch.uky.edu // Workgroup to be used, all clients should have the same workgroup

os level = 64 // set the OS level

// Below entries are important in order to tell that Samba server is the domain controller domain logons = yes pam password change = yes preferred master = yes domain master = yes local master = yes

In the [homes] section the following entries are important :

[homes] comment = Home Directories browseable = no writable = yes valid users = %S read only = no create mode = 0600 directory mode = 0700

logon home = \rch01\%U // This tells where is the home directory for the user

hide files = /*.pst/

In the [profiles] section the path variable tells where the profiles are to be placed and make sure the directories are created with right names

[profiles] create mode = 0600 directory mode = 0700 path = /home/samba/profiles/ profile acls = yes read only = no writable = yes

Configuring the Windows XP Client:

Notes : Only Windows XP-Professional Edition can join the Domain, it does not work for WindowsXP-Home Edition.

STEPS:

1) Make sure that the workstation belonged to the same workgroup as the server and have a fixed IP address and hostname assigned.

2) Change the registry entry, run the command regedt32 and do the below a) RequireSignOrSeal Registry hack

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netlogon\parameters "RequireSignOrSeal"=dword:00000000

b) Use the Registry Editor and edit the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\CompatibleRUPSecurity to have the DWORD value of 1

3) Use the Group Policy Editor (gpedit.msc) and enable "Computer Configuration\Administrative Templates\System\User Profiles\Do not check for user ownership of Roaming Profile Folders".

4) Go to MyComputer right click Properties. Go to Change and click on Domain and enter the domain-name you want to join. When joining the domain for the First time enter userid as root and give the samba password. Make sure there is an entry for the root in the smbpasswd (samba password) file.

5) Reboot and then the changes will be effective.

link

answered 11 Jun '10, 20:41

Ron's gravatar image

Ron ♦
9361618
accept rate: 13%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6

Asked: 11 Jun '10, 19:51

Seen: 3,549 times

Last updated: 14 Jun '11, 11:42

powered by OSQA