Hello , I ran this 'gconf-cleaner' just for the sake() on My Debian Box.

If I launch "gnome-terminal" from Applications Menu or from a panel icon ,it works with default $HOME directory(default behaviour). But ,with custom keyboard shortcut for Gnome Terminal in Gnome-2.30(Can set via menu System>Preferences>Keyboard Shortcuts),it opens in root directory.I mean in "/" directory. The Easy fix is to assign 'gnome-terminal --working-directory=%f ' or something similar.

Is there a way to fix this Behaviour without adding any lines to ~/.bashrc etc ?

BTW ,$HOME variable is correct.rest everything is Fine.

asked 15 Jun '10, 13:56

deepclutch's gravatar image

deepclutch
1111
accept rate: 0%

edited 16 Jul '10, 09:43

guerda's gravatar image

guerda
5533515

Please accept an answer so the question/answer can be finished. Or provide more details so we can help.

(20 Apr '11, 14:19) rfelsburg ♦



When you type Ctrl-Alt-T, or whatever key combination you set for "Open a terminal window" in Keyboard Shortcuts, gnome runs a specific command. This is defined by the gconf setting /desktop/gnome/applications/terminal/exec.

Run the gconf editor from Applications > System Tools > Configuration Editor and have a look at the value of this key. You'll probably find that instead of being just "gnome-terminal" it has extra arguments such as --working-directory=.... Reset it back to just "gnome-terminal" and it should start up in your home directory.

If it doesn't, then your default profile may have something unusual set in its preferences. In Terminal, select Edit > Profile Preferences and go to the Title and Command tab. Clear the boxes for "Run command as a login shell" and "Run a custom command instead of my shell".

Note that the /desktop/gnome/applications/terminal/exec_arg gconf key is for when you ask gnome to run a command in a terminal. You shouldn't need to change this.

link

answered 17 Jul '10, 23:20

Neil%20Mayhew's gravatar image

Neil Mayhew
312
accept rate: 33%

Most of your options are covered here.

Also, since you cleaned your gconf files, I took a look at mine. Seems like there are lots of references to various profiles. You might want to set up different profiles and see what happens.

link

answered 17 Jun '10, 18:00

Jazz's gravatar image

Jazz ♦
7811312
accept rate: 33%

Something weird.

If you set "Ctrl+Alt+T" then working directory is ~ If you set ie "Mod4+R" (mod4 is Windows key) then working directory is /

link

answered 10 Mar '11, 13:05

CS's gravatar image

CS
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×14
×3

Asked: 15 Jun '10, 13:56

Seen: 16,540 times

Last updated: 20 Apr '11, 14:19

powered by OSQA