Trying to install Ubuntu Studio 10.04 from the Alternate installation ISO image copied to Hard drive. Installation begins. After detecting Keyboard etc, I get this message


Detect and Mount CD-ROM
Your Installation CD-ROM couldn't be mounted. ... Try again to mount the CD-ROM?


I'm following this guide: https://help.ubuntu.com/community/Installation/FromLinux#Procedure%201

Running an existing Ubuntu 10.04. Copied these files to the present ext4 partition.

  • Alternate ISO image (to /)
  • vmlinuz, initrd.gz (from the ISO image to /studio/)

Edited Grub -

 menuentry "INSTALL ubuntu studio(iso on /dev/sda4)" {   
  insmod ext2   
  set root='(hd0,4)'  
  linux /studio/vmlinuz root=/dev/ram ramdisk_size=1048576 rw  
  initrd /studio/initrd.gz  
}

Basically copy-pasted grub entry for the existing installation and modified. ISO etc for new install is on the same drive, so I hope the hd0,4 numbers are correct. (besides, installation does begin.)

Tried with/without "root=/dev/ram ramdisk_size=1048576 rw" in 'linux /stu...' line. Still, "Your Installation CD-ROM couldn't be mounted". Any help is greatly appreciated.

I have 2 ubuntu installs: 9.10, 10.04. LVM and Non-lvm partitions. Couldn't burn a DVD or create usb startup disk.

Ananth

asked 17 Jun '10, 15:02

ananth.p's gravatar image

ananth.p
1313
accept rate: 0%

I'm curious... why can't you burn a DVD or create a USB on that computer or even on another computer?

(17 Jun '10, 16:24) Ron ♦

I couldn't do it on this computer. I thought it should be possible to install directly from hard drive, and indeed there was a way, and I had correctly downloaded the alternate iso.

There should be some simple fix, I guess. Otherwise I'll go get the dvd done from some other comp. But direct installation from image should be possible; having 2 existing ubuntu installs + 1 windows, all kinds of partitions: ntfs,ext3,ext4, and dozens of live cds lying around, it's a shame if it isn't possible.

(18 Jun '10, 07:23) ananth.p



You said you copied

  • vmlinuz, initrd.gz (from the ISO image to /studio/)

but the instructions you referenced say

Step 3. Grab the initrd.gz and vmlinuz files found in the following subdirectory of a Ubuntu mirror:

dists/gutsy/main/installer-i386/current/images/hd-media/

The initrd on the ISO looks for a cdrom, whereas the hd-media initrd knows to look on the hard drive.

link

answered 21 Jun '10, 14:26

npostavs's gravatar image

npostavs
963
accept rate: 42%

Wow! That worked!

I thought initrd and vmlinuz are generic files, and ISO and online versions would be same. Obviously wrong. Thanks for the answer.

(22 Jun '10, 18:44) ananth.p
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×90
×81

Asked: 17 Jun '10, 15:02

Seen: 8,200 times

Last updated: 21 Jun '10, 14:26

powered by OSQA